Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: new turbo and now blue smoke please help

  
  1. #1
    Status
    Offline
    sarahh9090's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    new turbo and now blue smoke please help

    I have just got my astra 2l turbo convertable back after my turbo began playing up. The garage sent the turbo off got it reconditioned and upgraded to a vxr spec, then had custom remap. Also new coil pack. I picked it up yesterday. I went for a drive earlier and the light came on the dashboard of a car and a spanner, the book says this is something to do with the electrics or auto gearbox (mines a manual). we have also noticed when idling blue/white plumes of smoke which get worse when i press the exelerator. Since the turbo was changed the garage have driven it to essex twice. I think its the tutbo am i right?

  2. #2
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    would say turbo seals or something relating to the turbo. Or oil seals of some description. I always thought that if you were idling around 1k then the turbo wouldn't be kicking in, so the smoke would only be seen when revved. Anyone clarify this as i know very little about turbo engines

  3. #3
    Status
    Offline
    Ben_M's Avatar
    AOC Obsessed
    Join Date
    Jul 2009
    Posts
    4,057
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    doesn't sound healthy, blue smoke indicates its burning oil. i'd be straight back to the garage monday morning, have you tried the pedal test to see what the fault code is?

  4. #4
    Status
    Offline
    sarahh9090's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Took it straight back to garage today the diagnostics machine did not pick anything up

  5. #5
    Status
    Offline
    sarahh9090's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The smoke only comes out in plumes when accelerator is pressed but you can see a hint of smoke when idling
    The garage seem to think its just oil from the before the turbo was reconditioned. Thing is they have drien it to essex twice since then which is a goo 60 miles from here, I would have thought that would have burnt any oil off

  6. #6
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    does it happen on boost?

    Could be valve stem oil seals, turbo oil seals.

    Edited: http://www.astraownersclub.com/vb/sh...d.php?t=230117

  7. #7
    Status
    Offline
    sarahh9090's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by gsi_10 View Post
    does it happen on boost?

    Could be valve stem oil seals, turbo oil seals.

    Edited: http://www.astraownersclub.com/vb/sh...d.php?t=230117
    Not to sure cant tell when im driving. As you can imagine im gutted i spent a alot of money and althogh it is much quicker its still not right

  8. #8
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    check the posts in the link for your symptoms. from what you have said it sounds very similar. Definitely not what you want to hear but better to find out and prevent any damage

  9. #9
    Status
    Offline
    sarahh9090's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by gsi_10 View Post
    check the posts in the link for your symptoms. from what you have said it sounds very similar. Definitely not what you want to hear but better to find out and prevent any damage
    omg that doesnt sound good thing is i took it into the garage because it was missing and smoking they said it was the turbo then realised the missing was the coil pack. Now they have fitted a new turbo at a tidy sum and it does not seem that it was causing the problem after all

  10. #10
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Needs a thorough investigation to find out for sure. Good luck and hope its not anything serious

Page 1 of 2 12 LastLast

Similar Threads

  1. Z20let with vxr turbo and blue smoke
    By vxr-chef in forum Turbo Petrol Engines inc. Transmissions
    Replies: 1
    Last Post: 06-03-2014, 17:42
  2. New vxr turbo and still some blue smoke
    By simonm1 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 30-05-2013, 15:56
  3. blue smoke from a sri 190 turbo
    By noidea in forum Turbo Petrol Engines inc. Transmissions
    Replies: 9
    Last Post: 07-09-2006, 21:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •