Results 1 to 4 of 4

Thread: exhaust emissions light & loss of power

  
  1. #1
    Status
    Offline
    ben_sri's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    280
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    exhaust emissions light & loss of power

    i drive an astra g 2.2 sri, a couple weeks ago i noticed the exhaust emissions light pop on (at the time i didnt know what it was), and also the engine felt like it was struggling. this was at high speed on the motorway, slowed down for a bit, and it went away pretty quickly and off i went and forgot about it.

    today i was doing around 40mph and the same thing happened again, the car accelerates, but very slowly and feels like the engines really struggling. this happened for a few mins until i could pull over, left it for 2 mins and it was fine again, and the light goes away.

    any ideas on whats wrong?

    cheers.

  2. #2
    Status
    Offline
    Ben_M's Avatar
    AOC Obsessed
    Join Date
    Jul 2009
    Posts
    4,057
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you tried the pedal test to see what the fault codes are?

  3. #3
    Status
    Offline
    ben_sri's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    280
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i've tried it, and the spanner light flashes once, and thats it

  4. #4
    Status
    Offline
    jamie1989's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    35
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    This hapened to me but the car went to limp mode, its either the cat which collapsed on me. or a lamber sensor may cause you the same problems if i remember correctly. try a diagnostic mate best way to find out, in ur case might be something loose or stupid as it happening accasionally whereas mine just went.

Similar Threads

  1. Coolant light Flashing & loss of power while light is on
    By Matt_H8 in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 14-02-2013, 17:26
  2. 2007 1.7 CDTI: Spanner Light then Oil Light then loss of power.
    By StevenH72 in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 15-09-2012, 08:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •