Results 1 to 9 of 9

Thread: engine trouble

  
  1. #1
    Status
    Offline
    Duncan Sxi's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    engine trouble

    ok i have an 04 astra gsi turbo.. it has 57k on it and standard turbo.. it uses no oil or water and doesnt smoke. the problems i was having is that it felt a little slow on power and wavey especially when cold. but now its thrown on the engine management light and gives the code p0530 which is something to do with the aircon but the aircon is working fine. now the car is very slow and wavey and using fuel like mad. so its in limp mode.. can anyoine suggest what else could be causing the code and wavey power??
    SRi-T Probably just over 200BHP

  2. #2
    Status
    Offline
    Duncan Sxi's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    also i can hear a more distinctive whooosh of air when boosting and louder wastegate or standard dumpvalve not sure which
    SRi-T Probably just over 200BHP

  3. #3
    Status
    Offline
    Duncan Sxi's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just reset my ecu. took the car for a spin and the light came back on. it now nearly cuts out when you stop and throws up the coolant light for a second then goes off but the engine management light remains. the p0530 has now gone but it now has p1106 and p0130. car is deffinately making a louder whoosihing noise at like 2000 rpm.. can someone help please
    SRi-T Probably just over 200BHP

  4. #4
    Status
    Offline
    Gaz GSi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    600
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    maybe a boost leak or a vac leak ?

  5. #5
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    p0130 02 sensor curcuit malfunction (bank 1 sensor 1)

    p0530 aa/c refridgerant pressure sensor curcuit malfunction

    p1106 boost pressure donor signal is not in the target area c-031

    have you done the earth mod????
    At the end of the day, it gets dark!!!!!

  6. #6
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Gaz GSi View Post
    maybe a boost leak or a vac leak ?
    yeah i was thinking that as well!!
    At the end of the day, it gets dark!!!!!

  7. #7
    Status
    Offline
    Duncan Sxi's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorted was a boost leak !!! suprising that it would cause all those effects though
    SRi-T Probably just over 200BHP

  8. #8
    Status
    Offline
    Gaz GSi's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    600
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sweet where was the leak

  9. #9
    Status
    Offline
    Duncan Sxi's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just after the map sensor where it joins to the intercooler it has some silicone pipes on it i soor a small amount of oil build up on it so felt round the back and there it was !!!
    SRi-T Probably just over 200BHP

Similar Threads

  1. MK4 engine trouble
    By astra_dan_87 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 8
    Last Post: 28-12-2009, 19:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •