Results 1 to 5 of 5

Thread: Z20LET Coolant light and fan

  
  1. #1
    Status
    Offline
    buzball's Avatar
    Supporting Trader
    Join Date
    Nov 2009
    Posts
    2,376
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z20LET Coolant light and fan

    Hello guys whilst i was fitting my front mount etc my aircon rad got a hole lol, i was waiting on the rad to come through so i put it all back together but left off the front aircon fan as i wont be using the aircon for a while yet

    The coolant light flicks on when the fan comes on and the light and the fan dont go off until i switch the engine off.

    Do i just need the plug the fan in to stop this happening??

    Do i have to plug the hole fan in or can i just do the resistor or something??

    Thanks

  2. #2
    Status
    Offline
    buzball's Avatar
    Supporting Trader
    Join Date
    Nov 2009
    Posts
    2,376
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    No one know then???

  3. #3
    Status
    Offline
    buzball's Avatar
    Supporting Trader
    Join Date
    Nov 2009
    Posts
    2,376
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Anyone????

  4. #4
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    You'll need the fan and resistor fitted back on, the cars noticing it's not there at the moment and throwing on a light to let you know it won;t work
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  5. #5
    Status
    Offline
    buzball's Avatar
    Supporting Trader
    Join Date
    Nov 2009
    Posts
    2,376
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok mate might whip it back on then

Similar Threads

  1. Coolant light is amber but coolant level and temp fine
    By GMSAstra in forum Astra Discussion & Chat
    Replies: 5
    Last Post: 04-10-2015, 21:49
  2. Replies: 0
    Last Post: 23-10-2013, 20:06
  3. Coolant light Flashing & loss of power while light is on
    By Matt_H8 in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 14-02-2013, 17:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •