Results 1 to 2 of 2

Thread: Z20let urgent help needed!!!

  
  1. #1
    Status
    Offline
    Matty_Robo's Avatar
    AOC Regular
    Join Date
    Feb 2008
    Posts
    90
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z20let urgent help needed!!!

    Hya Guys
    Last week i fitted a new coil pack and front bcs to my sri turbo.When i seemed to hit a bump it threw the engine managment light and spanner light up on the dash and jolted the car then wen't off again. Ive parked it up in the garage then got it out today.When i set off i got up the street and it threw the lights up again and the gauges wen't funny and it cut out. When i tried starting it the alarm kept going off and the gauges were been funny.Any ideas guys as it has blagged my head.lol


    Thanks in advance
    Matty
    Astra 2.0 Sri Turbo

  2. #2
    Status
    Offline
    Dele Z.'s Avatar
    AOC Regular
    Join Date
    May 2007
    Posts
    144
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Last time my car did that it was the Battery being dead, so maybe its knocked a power cable loose or something? just a guess
    MK4 Astra GSi in Flame Red

    Phase 1 + M32 6-Speed

Similar Threads

  1. Urgent Help needed Z20LET
    By mjL in forum Turbo Petrol Engines inc. Transmissions
    Replies: 9
    Last Post: 06-06-2009, 20:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •