Results 1 to 6 of 6

Thread: Help with my HIDs

  
  1. #1
    Status
    Offline
    Tom Clark's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,006
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Help with my HIDs

    Iv bought some HIDs but im completely stuck with them, i dont have a clue how to wire them up. Iv looked at other threads but none seem to be the same as mine.

    Can any one help? These are pictures of the kit i have and the plugs,








    So what do i connect to what i have FK angel eyes im hopeing to fit them to.

    Thanks, Tom.

  2. #2
    Status
    Offline
    RichT's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hey, I also have angel eyes and will fit my HID's soon. From what I gather, ignore the spade connectors and that whole cable all together. That is what confused me but you dont need it because they have the right connectors to fit straight in.

    The Ballast fits straight into the existing plug for the dipped beam or what ever your using from the battery, plug the bulb cable into the ballast and it's as simple as that as far as wiring goes, just as I said, ignore the spade connectors you don't need them. I am going to wrap mine in insulation tape but keep the cable there as it forms part of the rubber seal.

  3. #3
    Status
    Offline
    Ryan87's Avatar
    couldn't care less!
    Join Date
    May 2007
    Posts
    2,074
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Spade connectors go into the car, the sockets the bulb was plugged into, for power.

    Other end of that cable then plugs into the ballast to power it.

    Cable coming from ballast plugs into the bulb.

    Bulb goes in the headlight...

    You get the idea.

  4. #4
    Status
    Offline
    Tom Clark's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,006
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah now i look at it that makes alot of sense, its just the spade connectors dont fit into the socket from the car. Thats what confused me.

    Thanks for your help everyone.

  5. #5
    Status
    Offline
    Tom Clark's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,006
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They make a buzzing sound when they are on, is that normal?

  6. #6
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Tom Clark View Post
    They make a buzzing sound when they are on, is that normal?
    Yes.

    It will get quieter/go away once they have 'warmed up'
    The truth is always the truth even if you haven't realised it yet...

Similar Threads

  1. HIDs, in GSI
    By Totts in forum Electrical
    Replies: 1
    Last Post: 07-07-2011, 09:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •