Results 1 to 3 of 3

Thread: y17tid Won't Rev

  
  1. #1
    Status
    Offline
    deviator's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    y17tid Won't Rev

    Hello and thanks for reading.

    I've got an astravan with the 1.7tid engine, it's on a 51 plate. The problem I have is error code p1120. It doesn't respond at all to the pedal and holds a tickover of 1400rpm.

    This points towards the pedal, bought an ebay special and it's not made any difference. So borrowed a mates (known working) pedal from his car, still not working.

    As I am happy the pedal is not the fault, the next logical step is to check the wiring between the pedal and the ECU. I could do with some help here, colours, routing path etc; would be SO useful.

    If the wiring is fine my next step is the ECU, as I am aware these are prone to failing. I understand from what I have read, there is more than one ECU. So again any help pointing me in the right direction would be useful.

    Assuming none of that fixes the fault, than from basic knowledge of diesels, it could well be the ecu. With this in mind, is it possible to code the diesel pump myself? (I have a Tech2 copy <cough>).


    If anyone can help fill in the blanks or even suggest something I haven't considered, please do so! All help gratefully received.

    Thanks in advance, Dave.

  2. #2
    Status
    Offline
    deviator's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    OK got to the bottom of this last week. The pins on the ECU had been bent. Straightened them out.

  3. #3
    Status
    Offline
    sc16's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    94
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by deviator View Post
    Hello and thanks for reading.

    I've got an astravan with the 1.7tid engine, it's on a 51 plate. The problem I have is error code p1120. It doesn't respond at all to the pedal and holds a tickover of 1400rpm.

    This points towards the pedal, bought an ebay special and it's not made any difference. So borrowed a mates (known working) pedal from his car, still not working.

    As I am happy the pedal is not the fault, the next logical step is to check the wiring between the pedal and the ECU. I could do with some help here, colours, routing path etc; would be SO useful.

    If the wiring is fine my next step is the ECU, as I am aware these are prone to failing. I understand from what I have read, there is more than one ECU. So again any help pointing me in the right direction would be useful.

    Assuming none of that fixes the fault, than from basic knowledge of diesels, it could well be the ecu. With this in mind, is it possible to code the diesel pump myself? (I have a Tech2 copy <cough>).


    If anyone can help fill in the blanks or even suggest something I haven't considered, please do so! All help gratefully received.

    Thanks in advance, Dave.
    I have the same problem (stuck on 1400 revs. Went like that suddenly. Was it's repair relevent to the error code
    as mine doesn't show the code?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •