Page 1 of 4 1234 LastLast
Results 1 to 10 of 36

Thread: Astra turbo 'miss-fire' tuned z20let?? Please help

  
  1. #1
    Status
    Offline
    B1RDY's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra turbo 'miss-fire' tuned z20let?? Please help

    Hi. this is my first post but im desperate to find out whats wrong with my Astra SRi turbo 190. Its basically tuned upto 300bhp and has various VXR bits n pieces, MILTEK exhaust/sports cat etc. Ive only had the car a few months. basically under hard acceleration there seems to be a miss-fire / hesitation. The revs can be different each time. For instance at 4500 revs with foot flat to floor its as if the cars red-lining and loses power. Ive changed the Coil pack, tried a different VXR AFM, and today ive fitted a Walbro 255 uprated fuel pump as i heard the standard ones were only good to about 270bhp so thought this may be a cause. If anyones got any suggestions id be VERY grateful! Thankyou in advance

  2. #2
    Status
    Offline
    jafo666's Avatar
    AOC Fanatic
    Join Date
    Mar 2009
    Posts
    762
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What spark plugs are you running / when were they last changed?

  3. #3
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ad say plugs mate may need to be regapped or get iridiums

  4. #4
    Status
    Offline
    slim-shany's Avatar
    AOC Premium Member
    Join Date
    Oct 2009
    Posts
    2,535
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    you wont need the pump,as mine made 308bhp on regals rollers on the factory fuel pump.and was fine..

    if you have checked the obvious then best too get it on the rollers for a simulated test...

  5. #5
    Status
    Offline
    B1RDY's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi pal. Apparently they have them Ford cosworth ones as ive emailed the last owner asking the basics (like how old the fuel filter, plugs etc) but he said there only a few thousand miles old. Any idea whats best for these engines when modified and i can order some up. If they make no difference i can fit them to my Zafira GSi so nothing lost. Thanks mate

  6. #6
    Status
    Offline
    B1RDY's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Its been on the rollers a fortnight ago. The graphs from red dot were showing 302bhp, but when i got it tested it was giving out 286bhp & 340lb torque and the guy spotted the miss fire type issue. Ive ran about 3 tanks of Super in it in case it was just crap standard fuel. I just want this hessitation/miss-fire sorted then it'll go like s**t off a shovel. Cheers

  7. #7
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    how long has map been on car? what map is it?

  8. #8
    Status
    Offline
    B1RDY's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It was mapped by red-dot racing, London back in August 09. Cheers

  9. #9
    Status
    Offline
    B1RDY's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Just been looking through old threads about plugs. Im gonna order some off EBAY, '071 cossie plugs 8.95 with free p&p from zippyracing-online' and give them a whirl. If they make no difference i'll fit them in my Zafira instead.

  10. #10
    Status
    Offline
    kev007's Avatar
    Cumbrian RO
    Join Date
    Jul 2005
    Posts
    2,061
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i take it your the guy i was talking to with mark before. Least you got hold of a afm meter, i miss Marks call before was going to suggest changing plugs next, as getting the wrong gap may cause your problem.

    Did any fault codes come up?????
    Where are the Cumbrian Members??
    Anyone Seen Them!

    Drives a Fiat Bravo 165 sport....

Page 1 of 4 1234 LastLast

Similar Threads

  1. z20let miss fire
    By mikey_gsi in forum Turbo Petrol Engines inc. Transmissions
    Replies: 0
    Last Post: 13-06-2010, 18:40
  2. CS4 Z20LET miss fire
    By Danwileman in forum Turbo Petrol Engines inc. Transmissions
    Replies: 24
    Last Post: 31-10-2008, 17:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •