Results 1 to 6 of 6

Thread: astra 1.8 sxi idle and rev fault

  
  1. #1
    Status
    Offline
    stretch532's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy astra 1.8 sxi idle and rev fault

    I have a 52 plate astra 1.8 sxi 5door, not sure which engine model x18xe1, zx18 etc? The problem which has been getting worse over the last couple of weeks is that on start the engine is struggling to idle ie. revs drop down to 500 or so before rising up to 1300 and so on, after a period of time (which is ever increasing) it seems to settle down but mainly i have to keep revving the ti*s of it before it does. The other problem which im sure is associated with prob no1 is that the engine seems fuel starved or something. What i mean is that even with the pedal fully down it doesnt rev for a short time its as if no fuel is getting through? This eventually stops ie the engine revs but if i was to hold the pedal in a fixed poition the revvs hunt through a range(1500rpm up to 4000), again this stops after a while, it then seems to work properly ie idles(bit jumpy but not as bad as when first started) and hold a constant rev if the pedal is kept in one position, it's at this point the warning light comes on but the car runs ok untill switched off. I've given the throttle body a bit of a clean insitu, couldn't find the egr (if its got one), spark plugs seem normal, a friend has mentioned getting the ecu updated?? If any of you can offer any advice or tips or even how i can work out what engine model i've got id be very happy. cheers.

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    change the AFM for a new one and make sure it is a quality siemens one and you should be sorted. engine is Z18XE

    if the EML comes on you should be able to read a fault code

  3. #3
    Status
    Offline
    stretch532's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Guessing AFM is an air flow meter? I've done the pedal test and these are the codes:-
    0170 - fuel trim malfunction
    0100 - mass or volume air flow circuit high/low input. c-10
    0301 - cylinder 1 missfire detected. b-22
    0302 - cylinder 2 missfire detected. b-22
    0304 - cylinder 4 missfire detected. b-22
    1555 - throttle position sensor load signal not plausable with engine load. c-09
    0130 - O2 sensor incorrect signal. c-30.

    I've spoken to a vaux garage and the're recomending more diagnostics saying they'll get diff codes using their machine! I'm sceptical and think it will just be a waste of money. So im now in two minds what to do!! Help.

  4. #4
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    typical bunch of codes that will follow a faulty AFM that is not metering the air correctly, your code p0100 is the culprit

  5. #5
    Status
    Offline
    Aidan0810's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi guys, im having similar problems but the only code i get is p0304 Misfire C4. i have a Z18xe too in 03 plate sxi

    when i checked this out the sparplug was black at the tip and up some of the thread and was proper stiff to get out. I checked the others and they where a lot easier to get out and much cleaner however all where put in at same time 3mnth ago. so I fitted a new spark plug but no improvement. and now im stuck, i want to test the coil pack but if this was the problem wouldnt it give me a different code?

    and if it was the AFM then wouldnt i get a misfire on all the cylinders?

    any advise would be greatly appreciated?

    apologies for hijacking your thread but i've got EXACTLY the same symptoms.

    cheers

  6. #6
    Status
    Offline
    XxAstraxX's Avatar
    AOC Regular
    Join Date
    Aug 2010
    Posts
    190
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi have you sorted the problem?
    Car : Black 2001 Astra 1.8 SRi Irmscher

    Z18xe Stage 1

Similar Threads

  1. Astra Mk5 Z16XEP - Rough idle and fault codes for misfire on all cylinders
    By stevelewis_99 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 19
    Last Post: 26-02-2013, 19:45
  2. MK4 Astra 1.8sxi - Rough Idle+Fault Codes
    By abeckett in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 1
    Last Post: 18-05-2011, 15:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •