Results 1 to 8 of 8

Thread: Astra G Engine Management Light - Help? :@

  
  1. #1
    Status
    Offline
    JackHarding's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra G Engine Management Light - Help? :@

    Hi everyone, fairly new to the astra fold, only had mine since 15th Jan!
    (1.8 astra sport, 1998 mk4)
    (103,000 on the clock and a new cambelt at 99,00)

    Recently noticed the engine management light occassionally flickering on with a slight lack of power.

    Today coming out of the petrol station the engine management light came on and wont go off. The power seems to have dropped dramatically, literally 60% of the power has gone, accelerating is impossible and the engine suddenly sounds like a dirty diesel with a slight knocking noise.

    Ive checked the oil, air filter (changed a few weeks back), the maf sensor and the radiator. Everything seems fine.

    Any idea's what to check next?

    Thanks in advance!

  2. #2
    Status
    Offline
    Pce-gsi's Avatar
    AstraSport Member
    Join Date
    Oct 2009
    Posts
    1,469
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its gone into limp home mode thats why theres no power, check lamber sensor after cat and clean it
    Astra Gsi full miltek catback , tx enlarged top hat and boost pipe with Baileys dump valve , cdti air box

  3. #3
    Status
    Offline
    JackHarding's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers.

    So get the lamba sensor checked first of all?
    Quote Originally Posted by coupepaul View Post
    its gone into limp home mode thats why theres no power, check lamber sensor after cat and clean it

  4. #4
    vauxcoupe
    vauxcoupe's Avatar
    [QUOTE=coupepaul;2169451]its gone into limp home mode thats why theres no power, check lamber sensor after cat and clean it

    if its an xe18xe model theres no lamda sensor after the cat and just the one before the cat try that as mine was changed recently when i replaced my exaust,failing that check your egr valve? i did a check by buying a blanking plate and take the motor for a run. while your at it give the throttle valve a clean and am sure one or mabey two of the above problems will sort your motor.

    ignore this as a didnt read carefully and just noticed youve said 1.8 sport, but follow if its similar as most 1.8 are same as.

  5. #5
    Status
    Offline
    JackHarding's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    [QUOTE=vauxcoupe;2169478]
    Quote Originally Posted by coupepaul View Post
    its gone into limp home mode thats why theres no power, check lamber sensor after cat and clean it

    if its an xe18xe model theres no lamda sensor after the cat and just the one before the cat try that as mine was changed recently when i replaced my exaust,failing that check your egr valve? i did a check by buying a blanking plate and take the motor for a run. while your at it give the throttle valve a clean and am sure one or mabey two of the above problems will sort your motor.

    ignore this as a didnt read carefully and just noticed youve said 1.8 sport, but follow if its similar as most 1.8 are same as.
    Sorted the problem - Had a oil leak towards the spark plugs (seal)

    One of the sparkplugs had literally fallen apart, the end had crumbled

  6. #6
    vauxcoupe
    vauxcoupe's Avatar
    good stuff and glad you got it sorted.

  7. #7
    Status
    Offline
    jackmk4's Avatar
    AOC Newbie
    Join Date
    Aug 2011
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    engine light on due to new sport exhaust

    hi there

    i have today put a sniper exhaust on to my astra mk4 1.4 16v and i dove about 30 miles home it was all fine sounded great. i went back outside to go out started it and went about 100 yards and the light come on. Does anyone know what this might be??

  8. #8
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    Quote Originally Posted by jackmk4 View Post
    hi there

    i have today put a sniper exhaust on to my astra mk4 1.4 16v and i dove about 30 miles home it was all fine sounded great. i went back outside to go out started it and went about 100 yards and the light come on. Does anyone know what this might be??
    what year is the astra?

    you have most likely disturbed the position 2 oxygen sensor

Similar Threads

  1. Mk4 astra 1.7cdti engine intermittent engine management light
    By Michael Gillham in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 26-05-2015, 19:27
  2. Replies: 2
    Last Post: 31-08-2009, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •