Results 1 to 6 of 6

Thread: no engine temp reading on astra van 1.7 dti

  
  1. #1
    Status
    Offline
    Bess's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    18
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    no engine temp reading on astra van 1.7 dti

    Hi iv just bought a 2000 astra van 1.7 dti, it runs great its just that the temp dial does not move, the heater works fine and it did move about 2 mil but then went straight back down again, hasnt moved for afew days now.
    it also makes abit of a low squeal which sounds like its coming from a pulley just wondered if this might be connected to it.

    Any help much appreciated.

  2. #2
    Status
    Offline
    linlo1986's Avatar
    AOC Fanatic
    Join Date
    Oct 2009
    Posts
    304
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    must be the thermastat mate or a lose wire

  3. #3
    Status
    Offline
    pewseyfam's Avatar
    AOC Obsessed
    Join Date
    Jul 2008
    Posts
    1,579
    Mentioned in
    2 Post(s)
    Quoted
    2 Post(s)
    sounds like thermostat. the top radiator hose should stay cold until the car is upto full temp. if it is warming up as the engine warms up, then the themostat is faulty. It is possible to test the dash display with opcom and read the coolant temp from the sensor to see where the fault lies.
    T

  4. #4
    Status
    Offline
    Marc6678's Avatar
    AOC Fanatic
    Join Date
    Jan 2010
    Posts
    523
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Might just be the sensor mate, if that's the case there are plenty on ebay for about £10.

    Think this is what your looking for if so, the description is not very clear though.
    http://cgi.ebay.co.uk/ws/eBayISAPI.d...m=350236776544


  5. #5
    Status
    Offline
    Bess's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    18
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks guys for the replys, looks like im going to try a stat the weekend, cant see it being the temp sensor if the needle moves when the heaters are off, surely if it was the sensor it wouldnt move at all.

  6. #6
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    If the engine heats up OK & heater works, but the Temp guage doesn't move it will be the temperature sender, the wire or the guage itself. Most likely the temp sender.

    If it's taking ages to heat up it will be the thermostat.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

Similar Threads

  1. Astra h temp reading?
    By liamh1992 in forum Electrical
    Replies: 1
    Last Post: 27-08-2012, 14:59
  2. Temp reading Astra H
    By K3FUS in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 12-08-2007, 14:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •