Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Flashing oil light need advice

  
  1. #1
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Flashing oil light need advice

    as above.

    sat at traffic lights the oil pressure light starts to flash. engine is z18xe.
    when i move off its fine again. read up that its caused by the engine getting too hot. but iv changed the thermostat, stat housing and cts in the last week. coolant was also changed for new stuff. is there an airlock somewhere or a blockage stopping the coolant getting round?
    coolant will flow into the overflow tank and then suddenly it will stop flowing in and the top coolant hose (to the radiator) is very stiff, and have to unscrew the overflow cap to let some air out and then it will flow fine again. should i take it to a garage and have the system bled properly?

  2. #2
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    went out this morning, topped up the oil a bit, had a look underneath for any leaks and found that the subframe on the drivers side has quite a bit of oil on it right near to the flexi section which goes under the sump. none on the road though.

    is this a faulty oil pressure switch?

    ill also add that there are no engine warning lights.

  3. #3
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    anyone????

  4. #4
    Status
    Offline
    kingofkings's Avatar
    AOC Regular
    Join Date
    Nov 2008
    Posts
    248
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the exact same on my zafira mate, oil light now and then. done an oil change and been fine since. although i'm a bit worried as there was an oil change done just a few months ago. I suspect it might be the seals on mine.

  5. #5
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the subframe that connects to the wishbone is caked in oil but i cant find a leak anywhere. driven the car twice since the light was flashing yesterday and hasnt come on yet. where abouts is the oil pressure switch located?

  6. #6
    Status
    Offline
    kingofkings's Avatar
    AOC Regular
    Join Date
    Nov 2008
    Posts
    248
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    you got a haynes manual handy? I'd check but i'm not at home.

  7. #7
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeh iv checked in mine. looks in a bit of an awkward position. might give it a go in the morning

  8. #8
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    gonna try and get a new pressure switch from vauxhall tomorrow. think theyre only a few quid. ill probably see if a garage can do it

  9. #9
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    has anyone changed it themselves? id so what tool did you use? spanners?

  10. #10
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    went to fit the new oil pump switch...... bummer i dont have a spanner or socket wide/big enough to go round the little bugger. ah well will have to be a garage jobbie

Page 1 of 2 12 LastLast

Similar Threads

  1. Coolant light Flashing & loss of power while light is on
    By Matt_H8 in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 14-02-2013, 17:26
  2. Engine management light flashing (advice wanted)
    By jreedy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 10
    Last Post: 04-01-2013, 20:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •