Results 1 to 7 of 7

Thread: New exhaust, new fault codes

  
  1. #1
    Status
    Offline
    craig astra Mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2009
    Location
    Oswestry, United Kingdom
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    New exhaust, new fault codes

    Hope someone can help

    Just put a new scorpion back box and race tube on my Z18XE astra coupe. After fitting and taking it for a little spin the engine light has come on (not the ecu light with the spanner through it). Did the pedal test and the following codes came up:

    P1614 - SBDS Interactive Codes
    P0460 - Fuel Level Sensor Circuit Malfunction
    P0141 - O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

    I did turn the engine on when there was no exhaust fitted so maybe this has caused the problem. Left battery disconnected for over 20 mins and still not cleared.

    Has anyone got any ideas? Thanks in advance.
    Astra Coupe SE2 Auto-biography
    140 Bhp / 141 lbft
    http://www.astraownersclub.com/vb/sh...d.php?t=216060

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    you have probably dislodged the post cat O2 sensor that is bolted into the exhaust pipe just upstream from where your race tube is bolted

  3. #3
    Status
    Offline
    DrewWhelan's Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,445
    Mentioned in
    9 Post(s)
    Quoted
    6 Post(s)
    When mine was fitted they'd accidentally knocked one of the sensor plugs out, and my light came on, only worked out what it was after something rolled under the car and I noticed the plug hanging down.
    Plugged back in job done.

    Might be worth checking incase it's come loose

  4. #4
    Status
    Offline
    KevT.'s Avatar
    Yorkshire RO
    Join Date
    Jul 2005
    Location
    Bradford
    Posts
    9,218
    Mentioned in
    7 Post(s)
    Quoted
    15 Post(s)
    i had the same thing and it was the lambda senors plug that had come apart, pluged it back and it and drove fine but the light stayed on for quiet a few miles before going out by its self

    AOC top 15 car at PVS 2009 & 2010
    313.7bhp/343Ibft


  5. #5
    Status
    Offline
    craig astra Mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2009
    Location
    Oswestry, United Kingdom
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok thanks ill check to see if any of the plugs have been dislodged and try it again. Are the plugs just before the flexi joint. Dont think I could see any after it (if you work from engine to rear).
    Astra Coupe SE2 Auto-biography
    140 Bhp / 141 lbft
    http://www.astraownersclub.com/vb/sh...d.php?t=216060

  6. #6
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    should be just after the flexi joint going backwards from the engine

  7. #7
    Status
    Offline
    craig astra Mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2009
    Location
    Oswestry, United Kingdom
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Looked down behind the engine block and noticed that the second sensors had become loose when fitting the exhaust as you mentioned above. Plugged it back in and after a little drive it went off. Thanks for all your help, wish all things were this easy . Exhaust sounds a lot better now as well.
    Astra Coupe SE2 Auto-biography
    140 Bhp / 141 lbft
    http://www.astraownersclub.com/vb/sh...d.php?t=216060

Similar Threads

  1. fault codes
    By imrn in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 1
    Last Post: 27-05-2012, 20:18
  2. Temp gauge fault, 2 Fault codes
    By Autosparks in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 29-11-2008, 17:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •