Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Cooling problems.

  
  1. #1
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Cooling problems.

    right i changed the theromstat back in november for a new one as it was jammed open.

    astra with z18xe engine

    now iv got some cooling problems that started a few days ago.
    car does get up to temperature but takes a while. ( up to about 85 degrees) could take 15-20 minutes which is twice as long as it normally takes.

    then randomly when im on the move the temperature just goes down to less than 80 degrees and wont come back up to normal temperature until im sat at traffic lights.

    a) have i bought a dodgy stat?
    b) could it be the temperature sensor on the stat housing?

    i bought my thermostat from kevin cooper in plymouth. dont know if anyon else has had issues with their stats?

    help appreciated thanks

  2. #2
    Status
    Offline
    Markt82's Avatar
    AOC Regular
    Join Date
    Jun 2008
    Posts
    247
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)
    sounds like the thermostat staying open, this is what mine does and sometimes gets that cool that it goes back to reading nothing on the gauge esp on motorway runs.

    I had a tigra which had a thermostat stuck open and it would have freezing cold heaters until sitting at a junction warming up, which would be bloudy annoying in the winter lol

    Tbh i dont think cool running is really a problem, just with mine it makes it run like its just been started in the morning (bit lumpy/kangarooish) and is really annoying but my engine temps drop back a lot

    mark

  3. #3
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Cool engine running will increase fuel use, and the engine wear may be increased as the oil is not running at full operating temperature.

    Not sure if the overfuelling whilst driving all the time is also bad for the engine, it may or may not increase the chance of piston wash whereby the excess petrol thins the oil down and stops the pistons from being lubricated sufficiently.

  4. #4
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    anyone know where i can get the thermostat, housing and the temperature sensor all together for a decent price?

  5. #5
    Status
    Offline
    DaveTurbo's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Posts
    170
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could also be an airlock. check if the coolant is being returned to the expansion tank when the engines running.
    There should be a constant flow of coolant being returned to the tank through the small hose that goes to the side of the tank.
    If you got an airlock then sometimes theres no water around the CTS for it to get a reading.

  6. #6
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    theres coolant flowing mate. had the expansion cap off for 15 minutes to make sure there was no airlock too.

  7. #7
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    I just went to a dealer and used trade club. £25 or so for the thermostat, no idea on the CTS but think they're cheap enough, my wife's Vectra needed one and it was cheap if I recall.

  8. #8
    Status
    Offline
    benhavenhand19's Avatar
    AOC Obsessed
    Join Date
    Oct 2009
    Posts
    2,023
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    did you get a new housing too or just a stat?

  9. #9
    Status
    Offline
    DaveTurbo's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Posts
    170
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They usually come with the housing and cost around £20
    The CTS are around a tenner.
    Theres part numbers for the CTS and thermostat on this site somewhere, ill take a look for you.

  10. #10
    Status
    Offline
    DaveTurbo's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Posts
    170
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    THIS is what you need.im sure they can get you one.
    I got my CTS from them for the Z20LET, it was genuine BOSCH too.

Page 1 of 2 12 LastLast

Similar Threads

  1. Cooling problems..
    By mattyastra in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 5
    Last Post: 19-09-2012, 02:20
  2. cooling fan problems
    By Wildman in forum Electrical
    Replies: 3
    Last Post: 30-04-2012, 22:46
  3. cooling fan problems
    By boyracerv1 in forum Electrical
    Replies: 3
    Last Post: 04-09-2011, 17:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •