Results 1 to 9 of 9

Thread: What BHP should it be running??

  
  1. #1
    Status
    Offline
    B9NKO's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    What BHP should it be running??

    Hi this is the first time ive used this as ive just joined, i was just wondering what everyones opinion was of what sort of power my car should be running as i think it should be more?? its an arden blue gsi (z20let) with 25k on the clock, the previous owner had it re mapped by a company called r-tech and has a print out of 230 bhp and 250 ft lb , the mods that the car has are:-

    Front mount mount intercooler (tx Autosport)
    Enlarged top hat
    Vxr air flow meter
    iridium plugs
    K&n cone filter
    Full Miltek exhaust including sports cat and pre-cat de-cat
    Baileys dv

    if any one could give me any ideas i would appreciate it and where would be the best place to take it to check its set up ok or get it re-mapped cheers guys

  2. #2
    Status
    Offline
    flatfreeman's Avatar
    AOC Fanatic
    Join Date
    Sep 2009
    Posts
    517
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi mate and welcome

    Your just down the road from me, I would think that it should be outputting a little more than 230 for the mods its got aswell.

    Midpoint garage is the nearest recommended tuners to us :0)

  3. #3
    Status
    Offline
    MrStush's Avatar
    AOC Premium Member
    Join Date
    Jul 2008
    Posts
    2,625
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    It depends on what it was remapped to!.... The previous owner may have asked for power around that Mark.... Modifications are only a guideline as to the cars potential when it is remapped. i.e I could have a FMIC, Sports Cat, VXR Turbo, Iridium Spark Plugs but tell the tuner I don't want power above 230bhp.... Best bet is to get it on the RR...
    Star Silver SRI Turbo..'Red.Dot Reloaded'..Cybox Precat, Cybox Catback SS Exhaust..K&N Panel Filtered...9Ltr EDS SMIC!!.....

  4. #4
    Status
    Offline
    B9NKO's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok thanks where abouts is midpoint garage then not heard of them? The previous owner said it was a mod specific remap, but reading on here a few cars are running a bit more horsepower than mine with similar mods, also another question is sometimes when i sit in traffic and the cooling fan comes on the light on the dash appears (the pic of a radiator with a fan in the middle) it goes off and stays off if i turn the ignition on and off, dosnt always come on though??

  5. #5
    Status
    Offline
    MrStush's Avatar
    AOC Premium Member
    Join Date
    Jul 2008
    Posts
    2,625
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    A few people on here have had that issue before... Search for cooling fan or similiar see if there are any posts on how to resolve the issue..

    Midpoint Garage
    MPG,
    9 Valley Court,
    Sanderson Way,
    Middlewich,
    Cheshire CW10 0GF

    http://www.midpointgarage.co.uk/home.html
    Star Silver SRI Turbo..'Red.Dot Reloaded'..Cybox Precat, Cybox Catback SS Exhaust..K&N Panel Filtered...9Ltr EDS SMIC!!.....

  6. #6
    Status
    Offline
    B9NKO's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers for your help i might try and get to midpoint in the nxt couple of weeks get it on the rollers

  7. #7
    Status
    Offline
    flatfreeman's Avatar
    AOC Fanatic
    Join Date
    Sep 2009
    Posts
    517
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Does your intercooler kit have a single or twin fan? Single fans are known to cause warning lights because its not using asmuch power as the standard rad fan...

  8. #8
    Status
    Offline
    B9NKO's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    39
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its got twin fans on it? the weird thing is it wont do it all the time then all of a sudden the second the fan comes on the light appears, ive read up about cleaning the connectors do you think this could work or is something im going to just have to put up with? cheers

  9. #9
    Status
    Offline
    m5dkw82's Avatar
    AOC Obsessed
    Join Date
    May 2008
    Posts
    1,648
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Thumbs Up

    Quote Originally Posted by B9NKO View Post
    cheers for your help i might try and get to midpoint in the nxt couple of weeks get it on the rollers
    if your interested, there is a rolling road meet in February

    link to thread
    End of an era - She's gone to a good home

Similar Threads

  1. What boost should I be running?\possible running problem
    By CraigJG in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 11-10-2010, 18:01
  2. Car running sluggish due to running out of petrol????
    By voodoo_jellybaby in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 25
    Last Post: 21-12-2005, 20:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •