Results 1 to 3 of 3

Thread: astra mk4 fault code 0200!!!

  
  1. #1
    Status
    Offline
    johnjoesim's Avatar
    AOC Newbie
    Join Date
    Nov 2009
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra mk4 fault code 0200!!!

    Hi,
    Please help, i have an mk4 astra 1.4 16v, x14xe, now I have just changed the timing belt, alternator belt, spark plugs and I have cleaned the throttle body and attempted to clean the egr valve, attempted to turn the car on, it started for a few seconds then cut out with the engine light coming on, did the paperclip test andthe only fault code I got was 0200, which is fuel injector circuit malfunction, first off I changed back to the old spark plugs just in case, when removing the new ones i noticed that two of them were browny black (normal looking) but the other 2, (first 2 on the drivers side) looked brand new still, then I tried to turn the car on again and discovered it would stay on at high revs, I then went to see if it would idle after reving which it did but it was quite rough, sort of lumpy, now i dont think its the timingbelt because im fairly confident i did it right, i stand to becorrected on that however, would the egr valve have this effect on the car (cleaned it in the first place because car was jerking at low speeds) Really really need any help i can get on this, quite worried i could have f**ked it up....

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    some egr's do not respond well to cleaning, but from the description of the plugs and the code you have, i would seriously double check your timing belt and ensure that all the marks are lining up because if they are wrong then lumpy running and incorrect ignition timing will occur, which will have a knock on effect on the injection unit. another thing to look at, is did you remove the throttle body from the car to clean it?, if so ensure there are no manifold air leaks around the throttle body

  3. #3
    Status
    Offline
    johnjoesim's Avatar
    AOC Newbie
    Join Date
    Nov 2009
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Great thanks, yeah i think the tensioner is a bit dodgy so tightened it further and engine is now running smoother than ever thankfully, thanks again for your help, especially steve1412, without your comment probably would have left timing alone

Similar Threads

  1. Error code 0200
    By clanless in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 30-07-2009, 21:57
  2. Fault code 0200....cut out completly
    By Jay_R in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 12
    Last Post: 12-04-2009, 16:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •