Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: zaf wont start

  
  1. #1
    Status
    Offline
    paulrees05's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    zaf wont start

    hi everyone, sorry my first post is asking for help but im a bit stuck.
    I own a 2006 zaf b 1.9cdti and it wont start, its turning over but wont fire and the fuel pump sounds like it stays on for longer than usual, i did a pedal test and have got the following codes
    007071
    010008
    050071
    050074
    210304
    210306
    213970
    thanks in advance for any help
    paul

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    P0070 Ambient Air Temperature Sensor Circuit

    P0100 Mass or Volume Air Flow Circuit Malfunction

    P0500 Vehicle Speed Sensor Malfunction

    B2103 Antenna Not Connected

    B2139 Data Mismatch (receive data does not match what was expected)


    A few of them are a tad confusing - first 2 are the AFM (air flow meter) though

    but with all the others and the fact its not starting could be something else

    whats the battery voltage like? sometimes a dead battery can cause a multitude of elec problems - obviously u mention its turning over so doubtful its this

    Personally Id be looking at replacing the AFM first but theres a few things u can try

    first being unplug the AFM (it should be connected the the airbox at the front) - the car will be in limp mode but if it starts u know this is the cause

    failing that - locate the ECU and unplug the 2 big plugs for 20mins or so - this should reset any fault codes then start again

    You can disconnect the battery if u wish but in doing so you would need the stereo code etc and if u have an alarm it may cause more problems- therefore unplugging the ECU has the good effects of clearing codes but not the ill effects of disconnecting all the 12v accessories connected.


    HTH

  3. #3
    Status
    Offline
    Mixman's Avatar
    AOC Fanatic
    Join Date
    Sep 2007
    Posts
    451
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    P0070 Ambient Air Temperature Sensor Malfunction B-016
    P0100 Mass Or Volume Air Flow Circuit Malfunction
    P0500 Vehicle Speed Signal not plausible with Engine Speed and Injection Mass
    U2103 CAN-Bus Node no Communication
    U2139 CAN-Bus No Communication with CIM (Steering Column Module)

    It's the last 2 that are probably the cause.

    Something very wrong with the electrical system. Could be your key, try the spare, your CIM or something as bad as your ECU

  4. #4
    Status
    Offline
    a.tanasan@btinternet's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    652
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    fuel pump stays on for longer than usual
    (what you hear in there is the fuel pressure regulator)

    my guess would be the crank sensor , diesel engines needs the crank position info to inject the fuel otherwise the pump will not pressurize the rail ,therefore no pressure in the injectors either
    x18xe1 152bhp-136lbft

  5. #5
    Status
    Offline
    paulrees05's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks , ill try unplugging the AFM and then the ecuand see how it goes,
    the battery did start going flat at one point so try it when fully charged again
    thanks again
    paul

  6. #6
    Status
    Offline
    paulrees05's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by a.tanasan@btinternet View Post
    fuel pump stays on for longer than usual
    (what you hear in there is the fuel pressure regulator)

    my guess would be the crank sensor , diesel engines needs the crank position info to inject the fuel otherwise the pump will not pressurize the rail ,therefore no pressure in the injectors either
    wouldnt i get a code up for a crank sensor
    thanks
    paul

  7. #7
    Status
    Offline
    paulrees05's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Mixman View Post
    P0070 Ambient Air Temperature Sensor Malfunction B-016
    P0100 Mass Or Volume Air Flow Circuit Malfunction
    P0500 Vehicle Speed Signal not plausible with Engine Speed and Injection Mass
    U2103 CAN-Bus Node no Communication
    U2139 CAN-Bus No Communication with CIM (Steering Column Module)

    It's the last 2 that are probably the cause.

    Something very wrong with the electrical system. Could be your key, try the spare, your CIM or something as bad as your ECU
    could the bottom 2 be because the battery started going flat whilst trying to start it
    thanks
    paul

  8. #8
    Status
    Offline
    a.tanasan@btinternet's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    652
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by paulrees05 View Post
    wouldnt i get a code up for a crank sensor
    thanks
    paul
    not necessarily i didn't and was just that
    x18xe1 152bhp-136lbft

  9. #9
    Status
    Offline
    paulrees05's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by a.tanasan@btinternet View Post
    not necessarily i didn't and was just that
    anyway to test them and how much are they about
    thanks
    paul

  10. #10
    Status
    Offline
    a.tanasan@btinternet's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    652
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    38 quid at vaux ; it did came as a faulty on tech2 tho ; the test above is not 100 per cent reliable but once on tech2 you will have it running in no time

    and i had no eml light on either
    x18xe1 152bhp-136lbft

Page 1 of 2 12 LastLast

Similar Threads

  1. astra 08 diesel wont start,wont even turn over,no glow plug light
    By dogears in forum Diesel Engines inc. Transmissions
    Replies: 6
    Last Post: 21-04-2013, 21:51
  2. 1.7 DTI Engine wont start! had EDU repaired, and code reader wont conect!?
    By VTI_EG_DAN in forum Diesel Engines inc. Transmissions
    Replies: 16
    Last Post: 29-11-2010, 16:39
  3. Car wont start, will bump, wont lock?!
    By C9SRi in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 06-09-2009, 14:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •