Results 1 to 6 of 6

Thread: management light and turbo loss

  
  1. #1
    Status
    Offline
    leecoupeturbo's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    management light and turbo loss

    hi guys im new here iv got a 52 plate astra coupe turbo and when i hit 3500 revs in 5th gear when im not puttin my foot down just cruisin my turbo dies, engine management light comes on and traction control light comes on.

    the traction control light goes off next time i start the engine but managemnt light stays on for a few days then goes off.

    iv took the car to be plugged in to a fault reader and they told me i needed a part which i cant remember what it was. had 3 vacuum pipes and an electrical connector situated just on top of the turbo. not connected thou. this did f**k all and still happens.

    iv been told by a few people it COULD be my mass air flow meter but at £160 its a lot of money if it isnt.

    any advice would be a great help
    thanks
    lee

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    90% sure its the AFM

    TC & EML is a dead cert for AFM - but could be something similar such as BCS (boost control solenoid) or actuator/MAP sensor etc

    do the pedal test though see what comes up - if its P0100 or P0170 then AFM!

    Yes its £157 from the dealer iirc but u can get it for half that price for the 100% identical part

    Genuine Bosch one costs only £89.90 delivered here: http://cgi.ebay.co.uk/Vauxhall-Air-F...item2c52455b9c


    Pedal test if u aint got a clue can be found here (directly lifted from another thread but you get the idea): http://www.astraownersclub.com/vb/sh...78&postcount=2

  3. #3
    Status
    Offline
    leecoupeturbo's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thats brilliant nice one ill give it a go tomorrow now im hoping it is the mass air flow not fussed about spending the money its doin my head in drivin with it like it is.
    cheers matey

  4. #4
    Status
    Offline
    leecoupeturbo's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    right its comin up with 0100 so the afm needs replacing but it came up with this too

    P1106 boost pressure donor signal is not in the target area C-031

    thats what it said when i put it in google

    any ideas?

  5. #5
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    1106 can be quite a difficult one to cure

    the earth mod is something i would seriously suggest - as this can often cause false fault codes - 1106 and 0100 included

    may be worth doing this before u get a new AFM!

    details here: http://www.astraownersclub.com/vb/sh...d.php?t=117185

    as for the 1106... common causes can be the MAP sensor, BCS (Boost control solenoids) the Actuator itself, or maybe the small vacuum hoses that run between the BCS and the Actuator etc


    Id recommend the earth mod first and then consider other options

  6. #6
    Status
    Offline
    leecoupeturbo's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just looked at that post and it seems like it was causing the idle to f**k up. mine idles fine so not too sure if thats the problem.

    one thing a friend noticed while he was looking under the bonnet is that there is a non return valve missing where the vaccum pipe from the dump valve fits on. if that made any sense at all to you ha. would this cause any problems?

Similar Threads

  1. Engine management light and loss of power :(
    By JakeJones93 in forum Interior
    Replies: 8
    Last Post: 07-05-2014, 18:52
  2. x reg 1.8 16v sxi eratic idle. loss of power. management light.
    By calvert in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 03-01-2013, 08:28
  3. engine management light on & power loss
    By jerry_c1225 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 24-06-2007, 17:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •