Results 1 to 5 of 5

Thread: Looming compications, Z20let wiring on vxr z20leh

  
  1. #1
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,472
    Mentioned in
    141 Post(s)
    Quoted
    126 Post(s)

    Looming compications, Z20let wiring on vxr z20leh

    Hiya, I need some guidance,(in fear of either electricution or explosion)
    My project, mk4astra coupe turbo z20let(eng blown)repaced by new vxr z20leh, position; engine in situ, i kept the block/head/inlet manifold and throttle body/vxr turbo/ Replaced all wiring looms,gearbox ie f23/flywheel/clutch, z20let injectos n rail, and ign coil, ecu is the z20let, i am using the leh radiater and intercooler system, ac to be fitted,

    Point one the cam sensor has a different connecter,(altho the same? i think)2 maf sensor wiring had been extended, i have the afm z20let fitted, turbo pipes fully fitted, and i connected the radiater overflow to the header tank,(z20let goes to the turbo, but that appears to be bypassed with a duel feed to the turbo from the header tank leh piping used, and flows to the main rad hosing,(i think i'm right?).

    I think you have guessed by now, i am very green but beutiful, and i'm a HANDS ON person, never read instuctions etc, My problem;
    The engine fires up and runs, and when coming up to temp ticks over great(albeit no temp guage working, Think ive got the wiring wrong there somewhere)2 connecters are similar, 1 to the temp sensor the other? to i think the crank sensor (which is which? please advise) i only connected them where the loom would reach, the top single connecter is obvious, but is the single loose washer fitting wire, is it an earth? please advise, because when i touched it with the engine running my hair stood on end (a thrill i would not advise) What the heck i earthed it anyway, the engine still runs fine.
    So on start up, all cooling fans come on, there is flutter on eng beat until warm, i turned the vxr turbo boost down, revving up is very slow to respond,(could poss be turbo need turning down a bit more) NO temp guage, and i have checked ALL fuses as best i can.Definatly no overheating, rad system is up to temp, in car heater works.as all equiptment
    I'm thinking my engine is positively charged somehow , i tried a spare temp switch, and even removed ALL the realative connectors and the fans still operate,(until i remove the rad ecu connection,

    Please if there is anyone with the knowledge, let me know,your input is very welcome, but as i have previously mentioned i'm a HANDS on person and what i need is a side by side comparison, wire for wire, if there is someone local, i would love to hear from them, i live in Stockton near Newcastle area
    Best wishes for the new year evryone cheers Paula

  2. #2
    Status
    Offline
    Daddygsicool's Avatar
    Club Team
    Join Date
    Apr 2006
    Posts
    2,133
    Mentioned in
    7 Post(s)
    Quoted
    0 Post(s)
    welcome to the mad house well done so far dosnt sound like it will be hard to fix and im sure there will be someone along soon that can help
    Arden Blue Zafira Gsi

  3. #3
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if it wasnt so cold, my car wasnt slightly damaged off the snow, and i could get to u id have given u a hand but defeated by the weather on this one im afraid!

  4. #4
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,472
    Mentioned in
    141 Post(s)
    Quoted
    126 Post(s)

    Smile

    Thanks mates, and yeh we must all be mad, i freeze n gas myself in the garage, but with a few cans i crack on, i'm not bothered how long it takes,its just a project, to see if i can do it, so far with a little friendly comm ive done it alone, apart from a little assistance in lifting the subframe back in place,(complete with b new s rack and the pump, renewed wishbones, sus links, some new roll bar bushes, ) f23 gearbox is the 888 short shifter,balanced flywheel (new arp bolts) I need new discs, ss brake lines, but all in good time. The car moves albeit 10 yards in/out of garage, no leaks. having to sort out ac is a problem cos its wider but i will manage somehow, How important is the cam sensor? as i mentioned the plastik connecters differ, but i'm going to cannibalize the leh discarded loom,(which was cut in the first place by the seller of the engine(to me it would have been easier to unplug it, the rotters)
    Yeh call me mad, cos i had a 800mile trip to fetch the eng 20k miles back in my old vectra woah!! was that scary. but the good news so far is with juggling/selling other parts etc my costings so far are about 2k thats evrything, not bad so far, but i fear the ecu might need looking at, but step by step i 'l get there.
    The car is a 2001 bertone n very straight,leather with lots of xtras, and i will be keeping it in original condition as much as possible, unlike my other bertones. anyway i know i go on a bit, but please reply with your suggestions, because i am a novice cheers Paula And thankyou Geordiebandit (i guess your from Newcastle/Durham) When the weather improoves is it at all possible to pay a fleeting visit!!!!!!!!!?

  5. #5
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    sent you a pm

Similar Threads

  1. Z18XE to Z20LEH conversion wiring
    By Buddle in forum Electrical
    Replies: 4
    Last Post: 19-07-2012, 00:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •