Results 1 to 7 of 7

Thread: Temperature gauge being erratic! HELP!!

  
  1. #1
    Status
    Offline
    connerz's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Temperature gauge being erratic! HELP!!

    How now fellow Astra lovers! I am in a predicament! I bought my 2001 (Y reg) Astra 1.8 Sri yesterday....but the temperature gauge shows the car at complete zero even when the car is warm. I drove about 20 miles on the motorway with it like that but then i looked again and it was in the middle, where I think it should be when the car is warm....any ideas what the fault is? I have some knowledge of cars and I think possibly a faulty thermostat/temperature sender unit? Any one know any common faults its more likely to be?

    The car drives beautifully (gears 1 and 2 are hardish to engage sometimes but then it is an sri n has probably had some going)

    car has done 61000 miles.....Please help...connerz

  2. #2
    Status
    Offline
    phil w's Avatar
    AOC Obsessed
    Join Date
    Sep 2007
    Posts
    2,089
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi I would say this is more than likely the gauge it's self , which is not seperate you have to change the whole instrument panel speedo ect
    from an identical car petrol engined and has the same spec as yours so every thing iluminates

    And it doesn't matter if you cant get a speedo with the same mileage as yours as you can get the replacement corrected to match youre car

  3. #3
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    probs a faulty coolant temp sensor - it screws into the thermostat housing on your Z18XE

    because of this Id opt to kill 2 birds with one stone and replace both components seeing as u can buy them together

    £35 delivered and a total piece of piss to fit

    http://cgi.ebay.co.uk/Vauxhall-Therm...item2ea9b55d1a

  4. #4
    Status
    Offline
    astsa mk5 teo's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    622
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by GeordieBandit View Post
    probs a faulty coolant temp sensor - it screws into the thermostat housing on your Z18XE

    because of this Id opt to kill 2 birds with one stone and replace both components seeing as u can buy them together

    £35 delivered and a total piece of piss to fit

    http://cgi.ebay.co.uk/Vauxhall-Therm...item2ea9b55d1a
    What ever this good man says he's knows his shiz and i have listened to him for years now.
    I would wright something funny and clever but does anyone read these anyway

  5. #5
    Status
    Offline
    connerz's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers guys...I'll let you know the outcome! )))))

  6. #6
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the thermostat for Z16XE (my car) is £29 from vauxhall should be the same or similar for yours. Though thats on trade club (10% Off)

    This is what is wrong with mine, it only heats up whn the car is idling for 20mins and as soon as you turn the blowers on or set off it cools away off the scale again.

    Im fitting my new thermostat and housing in the next few days. Just getting the clutch done as well.
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  7. #7
    Status
    Offline
    connerz's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    31
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sorted it! It was the thermostat....Birds mum works for vauxhall so i got it done there cheap. Yes....I am lazy....
    I like to point my rear wiper wash straight out behind to wash the bus behind me - yeyaa!

Similar Threads

  1. Erratic fuel gauge
    By Graeme_Sxi in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 18
    Last Post: 29-11-2003, 16:19
  2. Erratic Temperature Gauge Problems
    By Portland Bill in forum Electrical
    Replies: 3
    Last Post: 29-11-2003, 11:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •