Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Burning smell through heater....

  
  1. #1
    Status
    Offline
    boze's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Burning smell through heater....(please tell me if its in the wrong forum!)

    Hey folks, ive just joined here and im not 100% sure if ive put this in the right forum..

    Ive got a 1997/8 Mk3 Astra LS(60) and recently im getting a pretty nasty burning smell through my heater. It seems to come and go but is gradually getting a bit worse I think. There is no smoke, and its not a burning smell that I recognise. The fan also doesnt work on 1, 2, or 3 which I have read is the resistor packs fault, could this be causing the smell too?

    Any help is greatly appreciated.

    D

  2. #2
    Status
    Offline
    boze's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Anybody? Im pretty sure its not burning oil or clutch....

    D

  3. #3
    Status
    Offline
    RhysD1309's Avatar
    AOC Fanatic
    Join Date
    Oct 2009
    Posts
    590
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if its any help, ive seen an iveco van with a pen stuck in the fan, causing the motor to burn and stink lol.

  4. #4
    Status
    Offline
    phil w's Avatar
    AOC Obsessed
    Join Date
    Sep 2007
    Posts
    2,089
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You could have wet/damp rotting leaves that have fallen in through the scuttle panel drying out causing the smell , and as you leave it over night it gets wet/damp again , It could also be something that has fallen into the heater from the inside via a vent do you have kid's in the car ?

  5. #5
    Status
    Offline
    RhysD1309's Avatar
    AOC Fanatic
    Join Date
    Oct 2009
    Posts
    590
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yerr chewing gum wrappers are quite common ^^^ lmaoo

  6. #6
    Status
    Offline
    boze's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hey, thanks for the replies. Theres next to no chance its anything from inside the car, ive no kids and keep things pretty clean in there...

    If its leaves etc then whats the best way to get them out again? Is there anything else it could possibly be? As it doesnt really smell much like leaves, more a synthetic burning....

    thanks again

    D

  7. #7
    Status
    Offline
    afcbadam's Avatar
    AstraSport Member
    Join Date
    Jul 2009
    Posts
    2,573
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    change the pollen filter, and clean the crap out from inside that bit.
    Astra T9 estate for sale, see my ebay link!

  8. #8
    Status
    Offline
    boze's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers folks. Will let you know how it goes, might be a few days as its a mates birthday tonight then the expected tomorrow :-)

    D

  9. #9
    Status
    Offline
    boze's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Burning smell through heater...**Update**

    Righto, I found the pollen filter and changed it but when I took the filter out I noticed that the block connector the wires go into at the front right of the filter housing was really badly melted. Does this block connect into the resistor pack? One of the wires going into the block is a bit melted too, does anybody know what part this is for me to order another? Im not very good with electric but is it relatively easy to cut the wires and put a new block on? The block that it connects into is a bit melted too....

    thanks in advance for any help...

    D

  10. #10
    Status
    Offline
    MarkC's Avatar
    AOC Obsessed
    Join Date
    Mar 2004
    Posts
    4,813
    Mentioned in
    1 Post(s)
    Quoted
    2 Post(s)
    Yeah I would say that you need to replace the wiring block and possibly the fan blower as the resistor pack may be overloading. Melted wires is a big concern, so you need to invcestigate what is causing that.

    You don't mention what the connector is for.....

    I can't recall how to get to the fan mechanisim, but it should be just a case of removing the scuttle pannel that covers the wiper mechanism, there you should find the heater/blower.
    Hey YOU See Oooour Reeegin Noooo ! Toss Yer Caber Here


Page 1 of 2 12 LastLast

Similar Threads

  1. zaf gsi burning smell please help
    By mif-bb in forum Turbo Petrol Engines inc. Transmissions
    Replies: 1
    Last Post: 20-03-2012, 14:40
  2. Burning smell when heater is on.
    By Le8 in forum Zafira Discussion & Chat
    Replies: 5
    Last Post: 11-11-2011, 21:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •