Results 1 to 4 of 4

Thread: Running Problem

  
  1. #1
    Status
    Offline
    Paddy_Flynn's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Running Problem

    Hello Guys, Ive Got A Running Problem With My 52 Plate !.4 Ls Astra, It Seems To Idle Alot, When You Stop At Traffic Lights Etc....I Was Told That It Was The EGR Valve So I Replaced That, And Unfortunately It Didnt Solve The Problem, Any Ideas On What It Could Be????

    Cheers

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what u mean as in idle alot?

    low idle
    high idle
    or just erratic idle

    as its a 52 plate theres no independent idle control valve - the next port of call must be the throttle body

    remove it fully from the car - just a few bolts, an elec plug and some coolant hoses (dont worry they wont spill as its not under pressure)

    soak the TB in petrol (some use carb cleaner but petrol is cheaper and cuts thru grime much better)

    make sure TB is nice n shiney before refitting it

    see how this goes

  3. #3
    Status
    Offline
    Paddy_Flynn's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yehh iratic idling mate

    someone sayed something about an air flow meter could be the fault? as this seems to be a common fault, as my mates coupe is doing it aswell

  4. #4
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    No air flow metre on your engine unless I'm mistaken. What EGR valve did you buy? If it was a cheap eBay one then I'd not expect it to help, they are rubbish - if it was a Delphi or OEM Vauxhall dealership part then fair enough, otherwise send it back and buy a decent one for a few quid more.

    Other than that I'd go with the above suggestion of cleaning the throttle body out.

Similar Threads

  1. problem when running
    By slodg69 in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 06-03-2012, 15:42
  2. What boost should I be running?\possible running problem
    By CraigJG in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 11-10-2010, 18:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •