Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: astra mk4 shakes and serious lack of power please help

  
  1. #1
    Status
    Offline
    viper77765's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question astra mk4 shakes and serious lack of power please help

    hi guys i was out the other day in the car all going well nd all of a sudden it went very lumpy like a cylinder had gone off so i went and bought new ht leads this morning with no luck so i went and bought a new coil pack and it is still the same

    with christmas tomorrow and living 20 miles from family my 6 month old wont get his prezis but more importantly i wont

    it shakes quite alot and still has lack of power shacking is less at higher revs but still no increase in power and lump but there is a serious bad smell of eggs aswell

    please help me

    paul
    thank you
    paul
    astra mk4 1999 1.6 8v velvet green

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,074
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    more than likely the cat has failed and either collapsed inside or blocked, hence the lack of power and rotten egg smell. try reading the ECU for any fault codes

  3. #3
    Status
    Offline
    viper77765's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers matey can i check it on the car and how or does it have to go to garage for the tech 2 thingyit is a 1999 (s) astra mk4 1.6 8v
    thank you
    paul
    astra mk4 1999 1.6 8v velvet green

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    paperclip test will work on your X16SZR engine

    details here (although lifted from another thread the general idea is the same)

    http://www.astraownersclub.com/vb/sh...69&postcount=4


    never discount the EGR valve though?

    grab a jerry can of petrol - remove the EGR valve and give it a damn good clean - remove the air intake resonator too (round thing ontop of inlet mani) and clean the throttle body too.... should make a big difference

    if not then the cat may be the problem!

  5. #5
    Status
    Offline
    viper77765's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi guys tried the paperclip test and nothing as it says bridge pins 5 and 6 turn key but do not start and the only lights to come on were oil water airbag and hand break as normal unless i start her in which case just the airbag light stays on

    no engine mag light no flashers or other wise
    thank you
    paul
    astra mk4 1999 1.6 8v velvet green

  6. #6
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    in that case id try cleaning the TB and EGR first - only take half hour or so

    details in how-to section although relates to other engines - procedure is similar tho

    EGR can often cause misfire type behaviour.... and a common issue

    give it a go..... if u want to that is!

  7. #7
    Status
    Offline
    viper77765's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i changed the egr valve cost 70 f&%*ing quid and still the same that makes 170 today

    it strage as there is no hestition in starting first turn of the key and away she goes she just feels like a load of people are shaking her and idle is low some one said that it could be the knock sensor but i have no idea what that is so i don't no

    what costs more the wife or the car to close to call for me

    paul
    thank you
    paul
    astra mk4 1999 1.6 8v velvet green

  8. #8
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if the idle is low have you checked/cleaned or replaced the ICV (idle control valve)

    if u do have to replace them - dont get cheapies as they are crap! Delphi brand only is my advice

    anyway, cleaning it should get you somewhere....... but that would usually only affect idle either under/over/erratic revving

  9. #9
    Status
    Offline
    MarkC's Avatar
    AOC Obsessed
    Join Date
    Mar 2004
    Posts
    4,813
    Mentioned in
    1 Post(s)
    Quoted
    2 Post(s)
    If you ahve changed the leads and coil pack and checked the CAT is OK, I change the spark plugs, could be a bad plug.
    Hey YOU See Oooour Reeegin Noooo ! Toss Yer Caber Here


  10. #10
    Status
    Offline
    viper77765's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the only thing i have not checked is the cat i no this might sound like a dumb question to you clever people but how do i check the cat do i have to remove the exhaust or cut it open

    could the cat be the cause of the lack of power though or the lumpy running
    thank you
    paul
    astra mk4 1999 1.6 8v velvet green

Page 1 of 2 12 LastLast

Similar Threads

  1. Astra lack of power
    By Benny-g in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 07-01-2014, 11:26
  2. astra gsi lack of power when hot
    By deanyb in forum Turbo Petrol Engines inc. Transmissions
    Replies: 8
    Last Post: 14-11-2011, 00:48
  3. dti astra lack of power fir 10 mls
    By kelso in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 30-12-2010, 10:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •