Results 1 to 7 of 7

Thread: juddery acceleration...

  
  1. #1
    Status
    Offline
    bassman9878's Avatar
    AOC Regular
    Join Date
    Aug 2008
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    juddery acceleration...

    hi guys, slight problem with my z14xe 2001,

    ive noticed recently usually in 2nd or 3rd theres a slight judder (almost loss in power) at about 2,000rpm and again at about 3,500, it happens mainly under hard acceleration and seems to be getting worse


    theres no warnin lights on dash and drives fine apart from this,

    recently been serviced with new plugs


    any suggestions??

    im thinking egr..

  2. #2
    Status
    Offline
    fourteenhundred's Avatar
    AOC Obsessed
    Join Date
    Sep 2006
    Posts
    5,423
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yer EGR valve is your best bet mate
    Vectra GSi SeatsHella Headlights
    17" alloysPiper 3" rolled exhaust
    GSi Bumper & skirts
    Dropped on Coilovers

  3. #3
    Status
    Offline
    scrim's Avatar
    AstraSport Member
    Join Date
    Aug 2009
    Posts
    1,532
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i get same sort of thing with a X16SZR engine and i've replaced the EGR with genuine one too :O

  4. #4
    Status
    Offline
    scrim's Avatar
    AstraSport Member
    Join Date
    Aug 2009
    Posts
    1,532
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    question though, do you notice your car performs better cold? and do you have a lets say, not so good MPG?

  5. #5
    Status
    Offline
    bassman9878's Avatar
    AOC Regular
    Join Date
    Aug 2008
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah mines a genuine egr changed not too long ago, guess il try cleaning that and the throttle body n c how we go if its still the same i think i'll live with it!!

  6. #6
    Status
    Offline
    bassman9878's Avatar
    AOC Regular
    Join Date
    Aug 2008
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah the car seems to perform better in the cold it always has done! the mpg seems fine though this never seems to have changed

  7. #7
    Status
    Offline
    scrim's Avatar
    AstraSport Member
    Join Date
    Aug 2009
    Posts
    1,532
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    maybe i mite be being a bit "critical" with the MPG lol, stop putting my foot down so much i think, costs too much... but yeah i've noticed the car actually moves when its cold, when warmed up, takes a while to climb

Similar Threads

  1. Z20LET bogging down under light acceleration, fine under hard acceleration
    By LeeMk4Turbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 04-09-2012, 11:31
  2. Help - Juddery acceleration!!
    By Ksmith_SE2 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 6
    Last Post: 20-04-2005, 20:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •