Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Help! Astra not starting when hot

  
  1. #1
    Status
    Offline
    Doc's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help! Astra not starting when hot

    Hi all,

    I have a problem with my 2002 Holden Astra that I cant seem to find an answer too. I have searched but cant find a solution anywhere.

    It has the Z18XE engine. After it gets warm, it just stalls. It is random and doesnt stall when it reaches a certain temp. I can leave it running in the driveway and the fans will cut in and out without stalling.

    The real problem though, is that most of the time it wont start after stalling. Leave it sit for 20 minutes to a couple of hours and it will start just fine. The car runs perfectly when it is running.

    When the car wont start, I get no engine light on the dash with the ignition on. After letting it sit I get an engine light again and off she goes again.

    I have so far replaced the crank angle sensor and coolant temp sensor.




  2. #2
    Status
    Offline
    MeasorPaul's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Location
    Hartlepool
    Posts
    3,198
    Mentioned in
    5 Post(s)
    Quoted
    2 Post(s)
    i would have it put on a comp to see if it has the faults listed, but at i guess i would say its the throttle body or the coil pack (if it has them) as this is what my gf had on her Z16XE used to do it all the time n i changed them and it was fine after but tech2 listed them as faults so mite be worth getting it checked
    Astra Coupe Turbo
    Custom Stage 3.5 330bhp 340ft lb VXR Pop Bang Map with Ignition Cut Limiter

  3. #3
    Status
    Offline
    Doc's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have had it checked for faults and there were none.
    I would of thought this is an electrical problem which would rule out the throttle body?

  4. #4
    Status
    Offline
    MeasorPaul's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Location
    Hartlepool
    Posts
    3,198
    Mentioned in
    5 Post(s)
    Quoted
    2 Post(s)
    oops i ment EGR valve
    Astra Coupe Turbo
    Custom Stage 3.5 330bhp 340ft lb VXR Pop Bang Map with Ignition Cut Limiter

  5. #5
    Status
    Offline
    Doc's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I've read the Z18XE doesnt have an EGR valve?

  6. #6
    Status
    Offline
    fourteenhundred's Avatar
    AOC Obsessed
    Join Date
    Sep 2006
    Posts
    5,423
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have read these symptoms before and have lead to ECU problems
    Vectra GSi SeatsHella Headlights
    17" alloysPiper 3" rolled exhaust
    GSi Bumper & skirts
    Dropped on Coilovers

  7. #7
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    The cars don't come with EGR valves so rule that one out

    Do the foot pedal test to see if any codes come up
    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  8. #8
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    needs tech 2 testing, it sounds like the typical Z18XE fault of the ECU overheating and once cooled will allow the car to run again. it is due to the position of the ECU and some dodgy internal componants, but tech 2 will confirm this for you

  9. #9
    Status
    Offline
    Doc's Avatar
    AOC Newbie
    Join Date
    Dec 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I've had a tech 2 on it and it shows no errors.

  10. #10
    Status
    Offline
    fourteenhundred's Avatar
    AOC Obsessed
    Join Date
    Sep 2006
    Posts
    5,423
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    this is what makes me think its ECU, As said its a common occurance on the 1.8's and with no errors being stored just kinda backs that up some more.
    Vectra GSi SeatsHella Headlights
    17" alloysPiper 3" rolled exhaust
    GSi Bumper & skirts
    Dropped on Coilovers

Page 1 of 2 12 LastLast

Similar Threads

  1. Help With Astra 1.6 8v - Not Starting.
    By Ste_K in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 21-03-2013, 23:41
  2. New Astra J - starting
    By noodles222 in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 02-01-2013, 08:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •