Results 1 to 7 of 7

Thread: Car falters, then blue smoke

  
  1. #1
    Status
    Offline
    chrisj's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    220
    Mentioned in
    1 Post(s)
    Quoted
    4 Post(s)

    Car falters, then blue smoke

    This niggly problem is drivin' me mad.......Only seems to happen on motorways & only briefly......the car will suddenly lose power & judder a bit & I get a puff of blue smoke.....after a few seconds it rights itself & is fine.......the car runs perfectly otherwise....I've just serviced it & changed fuel filter....the spanner light comes on briefly on occasions but then goes off again.........I have the error code P0370 showing up, but not sure whether this is recent...before I clear the code, does anyone have any ideas what the problem may be?.........any help appreciated.......thanks.....
    1.7 DTI Estate

  2. #2
    Status
    Offline
    chrisj's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    220
    Mentioned in
    1 Post(s)
    Quoted
    4 Post(s)
    OK...........Well, obviously no-one else has incurred this seemingly common problem............
    1.7 DTI Estate

  3. #3
    Status
    Offline
    dave234's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,312
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The opnly thing i can find is Timing Reference High Resolution Signal A Malfunction
    Mk4 ASTRA 1.7DTI Estate On 126K Miles Now 127k 11/10/2008 - - 129K 28/11/2008 - - 130k 04/01/2009 -- Now 138k 08/05/2009 Now 142k and a broken Diff -- 144K

  4. #4
    Status
    Offline
    dave234's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,312
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    looks to be part of set of codes:

    P0370 Timing Reference High Resolution Signal A Malfunction
    P0371 Timing Reference High Resolution Signal A Too Many Pulses
    P0372 Timing Reference High Resolution Signal A Too Few Pulses
    P0373 Timing Reference High Resolution Signal A Intermittent/Erratic Pulses
    P0374 Timing Reference High Resolution Signal A No Pulses

    Can be put down to cam shaft sensor or pump sensor
    Mk4 ASTRA 1.7DTI Estate On 126K Miles Now 127k 11/10/2008 - - 129K 28/11/2008 - - 130k 04/01/2009 -- Now 138k 08/05/2009 Now 142k and a broken Diff -- 144K

  5. #5
    Status
    Offline
    chrisj's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    220
    Mentioned in
    1 Post(s)
    Quoted
    4 Post(s)
    Hi Dave & thanks for the reply........'tis definitely an annoying little thing....I've checked all the wiring to & from the crankshaft sensor & all seems fine......If I know the problem lies there, I'll replace the sensor, but I wanted advice or views first, before I did it...........but thanks again.....
    1.7 DTI Estate

  6. #6
    Status
    Offline
    chrisj's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    220
    Mentioned in
    1 Post(s)
    Quoted
    4 Post(s)
    By the way Dave, when you say pump, what pump do you mean?
    1.7 DTI Estate

  7. #7
    Status
    Offline
    dave234's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,312
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i just googles the obd then the code and just serch some one on mig web had the issue
    Mk4 ASTRA 1.7DTI Estate On 126K Miles Now 127k 11/10/2008 - - 129K 28/11/2008 - - 130k 04/01/2009 -- Now 138k 08/05/2009 Now 142k and a broken Diff -- 144K

Similar Threads

  1. White smoke, blue smoke.
    By dp88 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 5
    Last Post: 03-04-2014, 23:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •