Results 1 to 3 of 3

Thread: Headunit not turning on??

  
  1. #1
    Status
    Offline
    A-S-T-R-A's Avatar
    AOC Newbie
    Join Date
    Nov 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Headunit not turning on??

    hey ive just come to fit an sterio into my car and it turned on but then i noticed a wier poking out so took it out pushed the wier in then went to put it back in and somthing sorted! so i replaced the fuse No.34 which works for the info display and radio the display turned on however the radio wont turn on... any sujestions???

  2. #2
    Status
    Offline
    astra sxi 2003's Avatar
    AOC Premium Member
    Join Date
    Jul 2003
    Drives
    1.6 SXI Astra mk4, 2.0 SRI Astra mk4 & Mokka 1.7 4x4
    Location
    Witham, Essex
    Posts
    2,185
    Mentioned in
    0 Post(s)
    Quoted
    3 Post(s)
    Follow astra sxi 2003 On Twitter Add astra sxi 2003 on Facebook
    what radio are you fitting?
    For all things Electronic, Electrical and Automotive
    Check out my web site www.daycall.co.uk
    x2 Astra mk4 1.6 16v & a Mokka 1.7

  3. #3
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Check fuse 21 along with any fuses that may be on the stereo
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Similar Threads

  1. Replies: 7
    Last Post: 07-10-2009, 12:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •