Results 1 to 5 of 5

Thread: Help - Persistant Coolant Leaks

  
  1. #1
    Status
    Offline
    scott295's Avatar
    AOC Regular
    Join Date
    Nov 2003
    Posts
    221
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help - Persistant Coolant Leaks

    I don't know if anybody here has come up against this problem but I am having some seriously problems with Coolant leaks on my 56 plate Astra Sri 2.0t (200PS).

    I bought the car from my local dealer at the end of July 2008 and noticed it losing a bit of coolant which I topped up but the leak got faster. I took it in to the dealer in November and they replaced a 'Coolant Feed Line (Turbocharger)' under warranty.

    All seemed well until May 2009 when the problem came back again but this time there was an oil leak as well...they kept the car for two days and changed the same thing again as well as a clamp and some other parts. The oil leak was the rocker cover gasket and some other seals.

    Problem is now back again in November 2009 but I am not 2 months out of warranty and they want £500 to repair it.

    Anybody else had this kind of problem or offer any advice? Is it normal to have this many problem with hoses and seals on a 2-3 year old car?

    Cheers in advance for any advice.
    5-Door Star Silver Astra SRi 2.0 Turbo (200bhp) with Exterior Pack

  2. #2
    Status
    Offline
    caravanj's Avatar
    AOC Newbie
    Join Date
    Nov 2009
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Contact your Trading Standards office because under consumer protection laws any item has to be capable of lasting a reasonable time & this includes cars.
    A landmark ruling against Landrover identified this law when Landrover had engines blowing up after 60,000 miles & out of their warranty. A Court decided that their engines should last well in excess of 60,000 miles & ordered Landrover to repair / replace all affected engines free-of-charge.
    A 2 to 3 year old car should not be losing oil & coolant after 2 attempted repairs.

  3. #3
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    As above, stand your ground with them.

  4. #4
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    This is a easy one they fixed the car when it was in warranty an they will warranty repair for 1 year

  5. #5
    Status
    Offline
    scott295's Avatar
    AOC Regular
    Join Date
    Nov 2003
    Posts
    221
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers for the replies guys.

    I spoke to the service manager and he believes the faults are not the same as they replaced different parts of the cooling system. I have asked them for the invoices for the warranty repairs and written quotation for the new repair and the majority of part numbers replaced are the same although they have given them different names on the quotation. The problem seems to be the coolant feed to the Turbo and an oil return pipe.

    As far as they are concerned its not the same fault if there is more than 3 months between repairs.

    I have taken the car back unrepaired until I look into it more and get pro advice. I've spoken to Vauxhall to compain about the dealership and they have offered 20% contribution as goodwill but I don't find this acceptable and it should be down to the dealer to cover the full cost.

    I have also logged a complaint with the Finance company who are going to investigate and I am going to detail my compaint to the dealer formally in writing.

    I'll keep you posted on what happens but if anyone has any more advice or knows if its a common fault let me know.
    5-Door Star Silver Astra SRi 2.0 Turbo (200bhp) with Exterior Pack

Similar Threads

  1. Oil and coolant leaks...Help please?
    By Matty-M in forum Turbo Petrol Engines inc. Transmissions
    Replies: 15
    Last Post: 16-04-2013, 23:07
  2. Coolant leaks
    By bredsticz in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 7
    Last Post: 29-07-2011, 12:51
  3. z20let loosing coolant with no leaks?
    By vauxtillidie in forum Turbo Petrol Engines inc. Transmissions
    Replies: 26
    Last Post: 03-08-2009, 14:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •