Results 1 to 6 of 6

Thread: Z20LET Clicking Noise

  
  1. #1
    Status
    Offline
    Minty's Avatar
    AOC Fanatic
    Join Date
    Jan 2004
    Posts
    399
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question Z20LET Clicking Noise

    Hi All,

    I have just bought an astra turbo and there seems to be a slight clicking noise coming from the battery side of the engine when the ignition is on but engine not running. The noise it still there when you start the car but not sure what it could be. Just wanted to know what might need replacing?

    Cheers

    Minty

  2. #2
    Status
    Offline
    BMAstra's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,588
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could possibly be the aux water pump

  3. #3
    Status
    Offline
    Minty's Avatar
    AOC Fanatic
    Join Date
    Jan 2004
    Posts
    399
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I thought the water pump is belt driven??

  4. #4
    Status
    Offline
    DCA's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    523
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    There is a Aux water pump minty just below the battery extra to the normal water pump

  5. #5
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Minty View Post
    I thought the water pump is belt driven??

    the main pump is yes

    but the auxillary pump is 12v electric feed and sometimes runs with ignition on prior to starting (mine does)

    most models however only seem to chirp into life very rarely once engine has been switched off and been seriously thrashed etc


    anyway it would be more of a buzzing noise as opposed to clicking

    any chance of a vid or sound clip of it? how long does it last?

    theres a few things that can click such as carbon canister solenoid (but only when running - sits ontop of airbox)

    another option is the throttle body self test prior to start up - but again this is nowhere near the battery!


    if u think its the aux water pump its bolted to the front of the gearbox with 2 water hoses off it. u cant really miss it

    try disc the plug to pinpoint it is that - if it is - just leave it - its doin its job afterall

  6. #6
    Status
    Offline
    Minty's Avatar
    AOC Fanatic
    Join Date
    Jan 2004
    Posts
    399
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the help guys, think it might be the aux water pump but will look into it in more detail tomorrow.

    Getting cambelt and service done so can ask mechanic as well. Cheers again.

Similar Threads

  1. Clicking Noise
    By Cchris in forum Chassis
    Replies: 2
    Last Post: 26-09-2013, 14:39
  2. Clicking noise
    By PAFC BUCKY in forum Turbo Petrol Engines inc. Transmissions
    Replies: 16
    Last Post: 16-05-2009, 11:49
  3. clicking noise
    By tim1547 in forum Chassis
    Replies: 1
    Last Post: 14-07-2008, 09:45
  4. clicking noise
    By snookssxi in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 27-03-2006, 18:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •