Results 1 to 5 of 5

Thread: throttle over run and bad starting when warm

  
  1. #1
    Status
    Offline
    lgreatrix's Avatar
    AOC Newbie
    Join Date
    Mar 2008
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    throttle over run and bad starting when warm

    firstly battery ok, starter ok, throttle body cleaned out twice, new plugs, crank sensor and water temp switch.

    Right why is it that my astra starts 1st time when cold and after letting it stand for 10 hours plus??? But once it has been started it is then difficult to get it to fire up again resulting in prolonged cranking.

    Also on the throttle overun there does seem to be a noticeable un smoothness to the engine during the off throttle period.

    Fly by wire throttle...

  2. #2
    Status
    Offline
    carlucci7's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    89
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had the same thing its your egr valve its stuck open beacause when its hot and your trying to start it ure starting it with hot air try blanking it and see if it helps if it does buy a new one i recomend delphi more expensive but less hassle in the long run

  3. #3
    Status
    Offline
    lgreatrix's Avatar
    AOC Newbie
    Join Date
    Mar 2008
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Fly by wire system, my engine is late enough not to have an EGR valve.. any more ideas???

  4. #4
    Status
    Offline
    carlucci7's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    89
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what engine do you have then

  5. #5
    Status
    Offline
    lgreatrix's Avatar
    AOC Newbie
    Join Date
    Mar 2008
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it is the z18xe 2002 fly by wire without the egr valve and separate map sensor, air temp sensor built in to the airflow meter.

Similar Threads

  1. Problem Starting When Warm
    By joeparsons84 in forum Diesel Engines inc. Transmissions
    Replies: 13
    Last Post: 08-05-2011, 23:24
  2. Warm starting
    By Pete2Astras in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 1
    Last Post: 02-04-2007, 14:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •