Results 1 to 7 of 7

Thread: Z16XE LPG Problem

  
  1. #1
    Status
    Offline
    curwinkle's Avatar
    AOC Newbie
    Join Date
    Nov 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z16XE LPG Problem

    Sorry if I'm in the wrong section here...

    I've got a mark 4 2002 Dualfuel Astra. Had to replace the engine recently and am unable to get the car running on LPG. The engine code is Z16XE (means nothing to me but hope someone out there will know).

    Basically the car runs sweet as a nut on Petrol, switched over to LPG it cuts out. I got the car to cut down on fuel expenditure so am eager to get the problem resolved. Any help or advice would be greatly appreciated.

    I read somewhere that the inlet manifold (again hoping someone else might understand what that is) could be something to do with it, or there could be problem with the pressure and to check the pressure regulator (again ). I'm a complete novice when it comes to cars if its not about driving it .

    Thanks in advance.

  2. #2
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Welcome You have the same engine and a similar or identical LPG system too!

    Z16XE refers to the 1.6 16v engine with a fly-by-wire throttle...

    My car did the exact same thing when I first got it (new) but I can't say what Vauxhall did to fix it. I'll send a PM with some additional info in.

  3. #3
    Status
    Offline
    Afy01's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    SAME!..My Car Does The Same Thing..Cant Figure Out What It Is Though..I Have Changed The Engine Recently Too and Now The lpg cuts out!

  4. #4
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Thought I'd seen it before

    You can read error codes on some LPG systems (mine is a GSI setup), do you know what systems you both have?

  5. #5
    Status
    Offline
    Afy01's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Dont know what system it is mate..are you talking about the make of the lpg system..i think its KOLTEC but i am not sure

    how do we find out the fault codes?

  6. #6
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    KOLTEC parts are fitted to the GSI and EGI systems that were factory fitted around the age of your car/my car, so it isn't a KOLTEC system. Any pictures of your engine bay?

  7. #7
    Status
    Offline
    Afy01's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it says KOLTEC on the vapouriser lol
    erm..ill get some pictures tomorrow or something

Similar Threads

  1. Z16xe running problem
    By LeeJarvis in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 13
    Last Post: 26-07-2013, 20:32
  2. Z16xe engine problem
    By 8vcorsa in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 26-03-2013, 23:09
  3. clutch problem - Z16XE
    By MeasorPaul in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 6
    Last Post: 27-08-2008, 13:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •