Results 1 to 9 of 9

Thread: 'Coolant Warning' wont go off!

  
  1. #1
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question 'Coolant Warning' wont go off!

    I came to my car the other day and the 'coolant level' warning came up on the MFD, when I checked the level it is fine so I can only assume what ever sensor picks this up is faulty!
    If people agree, where is the sensor?
    If not could the car just need the codes resetting?
    Thanks in advance.

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    will be a faulty sensor

    on the underside of the coolant tank - u may have to drain the system to get the tank up out the way to access the sensor though

    or at least the amount thats in the tank anyway - ie undo all the hoses and then unlcip the tank from the retaining clip at the top and it should lift up

  3. #3
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers bud, well thats a pain in the arse I just drained the car a week ago and filled with anti freeze! i'll try cleaning it first, then if that doesnt work ill get a new one. Thanks again bud.

  4. #4
    Status
    Offline
    rhys57's Avatar
    AOC Obsessed
    Join Date
    Apr 2005
    Posts
    2,348
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sensor maybe?
    Vxr turbo with 360 bearing and twin oils seals & Evoms dv. Cdti airbox 63mm tophat.Milltex cat back and pre cat.. Regal 245 leh phase 1 ipf remap.Whiteline rarb.

  5. #5
    Status
    Offline
    m5dkw82's Avatar
    AOC Obsessed
    Join Date
    May 2008
    Posts
    1,648
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sensor part number 9117438 retail £16.85 + vat

    I have a brand new one which I dont require (£15 delivered if your interested)
    End of an era - She's gone to a good home

  6. #6
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the problem but I took it out for a good run yesterday and it seems to have cleared but I have your details and if it plays up again i'll buy it, cheers.

  7. #7
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorry to bring this up again but this fault came up again so i fitted a new sensor on the coolant bottle and the cooling level warning is still showing even though the level is full and the new sensor is fitted! anyone have any idea why this might be?

  8. #8
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    try shorting the connector out and see if the display clears
    ARDEN BLUE GSI

  9. #9
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i assume this is checking the switch? if the switch test ok any suggestions? cheers guys

Similar Threads

  1. Coolant sensor wont fit in coolant bottle!
    By Gary_D in forum Turbo Petrol Engines inc. Transmissions
    Replies: 13
    Last Post: 14-03-2011, 08:05
  2. Airbag warning light wont go away!
    By Armychris810 in forum Electrical
    Replies: 4
    Last Post: 27-09-2008, 04:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •