Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: TC light stays on

  
  1. #1
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    TC light stays on

    Hi all.

    My TC light stays on ATM, I'm not sure why.

    Recently my abs loom snapped on the back, I've replaced the loom.

    however the plugs are in oppersite way, i didn't think it'd matter...

    basically n/s/r is plugged into o/s/r and vice versa.
    Surely this cant be the problem?

    Its also the only electrical/wiring item replaced on the car recently.

  2. #2
    Status
    Offline
    300bhpzafira's Avatar
    AOC Premium Member
    Join Date
    Feb 2009
    Posts
    475
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nyzrox View Post
    Hi all.

    My TC light stays on ATM, I'm not sure why.

    Recently my abs loom snapped on the back, I've replaced the loom.

    however the plugs are in oppersite way, i didn't think it'd matter...

    basically n/s/r is plugged into o/s/r and vice versa.
    Surely this cant be the problem?

    Its also the only electrical/wiring item replaced on the car recently.
    mine does this every now and then when on turn ignition off does it go away? as mine does and its when you drive hard in first

  3. #3
    Status
    Offline
    Glasgow_Stu's Avatar
    Moderator
    Join Date
    Nov 2005
    Drives
    Vectra VXR + Astra Coupe Turbo
    Location
    In a box outside tesco
    Posts
    12,987
    Mentioned in
    25 Post(s)
    Quoted
    16 Post(s)
    Add Glasgow_Stu on Facebook
    mine was doing it last week and replaced the AFM and all was ok.. started the other day while giving it some free space and it done it again.. i usually just turn off the car and start it and its fine.... check for fault codes tho just incase

    also.. has oit just started doing it and is it on all the time m8?
    The coupe...ITS ALIVE & back from the dead....again!
    The internet: where everybody knows everything about **** all.

    become a paid member:
    http://www.astraownersclub.com/vb/payments.php



  4. #4
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by 300bhpzafira View Post
    mine does this every now and then when on turn ignition off does it go away? as mine does and its when you drive hard in first
    All time.


    Quote Originally Posted by Glasgow_Stu View Post
    mine was doing it last week and replaced the AFM and all was ok.. started the other day while giving it some free space and it done it again.. i usually just turn off the car and start it and its fine.... check for fault codes tho just incase

    also.. has oit just started doing it and is it on all the time m8?
    Its on all the time.

    Had accident an snapped wheel an the abs loom snapped.

  5. #5
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Anyone near you that can read the codes?
    The truth is always the truth even if you haven't realised it yet...

  6. #6
    Status
    Offline
    Matt_GSi's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,228
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    are there any sensors on the back? they plugged in right? id try swapping the plugs around

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have any of u lot done the earth crimp mod? if not then do it

    i always had this on mine - did the mod and never appeared again

    some say it only affects early models but for the sake of half hours work its a worthy mod

    details here for those who aint got a clue what im waffling on about: http://www.astraownersclub.com/vb/sh...d.php?t=117185

  8. #8
    Status
    Offline
    ste_h_88's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    743
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    that cables used on that guide is way too big
    Arden Blue Astra GSi




  9. #9
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by lee gsi View Post
    Anyone near you that can read the codes?
    I can read them,

    Theres none, ive reset the ecu
    Quote Originally Posted by Matt_GSi View Post
    are there any sensors on the back? they plugged in right? id try swapping the plugs around
    Theres 2 sensors, both for ABS, 1 per hub.
    Quote Originally Posted by GeordieBandit View Post
    have any of u lot done the earth crimp mod? if not then do it

    i always had this on mine - did the mod and never appeared again

    some say it only affects early models but for the sake of half hours work its a worthy mod

    details here for those who aint got a clue what im waffling on about: http://www.astraownersclub.com/vb/sh...d.php?t=117185
    Never had the problem before the accident...

  10. #10
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by ste_h_88 View Post
    that cables used on that guide is way too big
    if u read the guide youll see he is fully aware of that

    its only a guide anyway - clearly points out the correct way to do it ie smaller gauge wire - anyway thats by the by

Page 1 of 2 12 LastLast

Similar Threads

  1. air bag light stays on
    By the wizard in forum Electrical
    Replies: 7
    Last Post: 13-06-2014, 15:32
  2. TC light stays on?
    By GhostOPC in forum Chassis
    Replies: 5
    Last Post: 20-07-2011, 08:09
  3. Car fault light, then oil light flashes, then stays on?
    By Alex991 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 20
    Last Post: 29-03-2010, 00:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •