Results 1 to 10 of 10

Thread: Maf and traction control

  
  1. #1
    Status
    Offline
    BMAstra's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,588
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Maf and traction control

    not sure if the has been asked but why would a faulty maf stop the TC/ESP from working, Makes no sense

  2. #2
    Status
    Offline
    MonkeeBoy's Avatar
    AOC Obsessed
    Join Date
    Jan 2008
    Posts
    2,416
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    aaah yes was gonna ask when mine went but forgot :P
    Also sprung up the ABS and the seatbelt light for some unknown reason... but then again the mechanic was clearing faults with the computer at the time
    >>Diary<< Status: ...........Slow and Steady.... may update more often...
    Last Updated: 27/10/2014

  3. #3
    Status
    Offline
    cwaigy's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    312
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I find it odd too. Whenever my AFM has gone it normally happens like this:

    • Engine management light briefly comes on.
    • TC light also comes on around the same time.
    • The Engine management light goes out.
    • The TC light stays permanently on.
    • Stopping and starting the engine clears the TC light.
    (with the above happening intermittently.)

    Cheers,
    Craig

  4. #4
    Status
    Offline
    BMAstra's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,588
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the tc light on then the spanner with car and after a few mins the eml

    but mine was constant seems mine just gave up yesterday

  5. #5
    Status
    Offline
    Glasgow_Stu's Avatar
    Moderator
    Join Date
    Nov 2005
    Drives
    Vectra VXR + Astra Coupe Turbo
    Location
    In a box outside tesco
    Posts
    12,987
    Mentioned in
    25 Post(s)
    Quoted
    16 Post(s)
    Add Glasgow_Stu on Facebook
    the TC light is tell tale sign the AFM has gone or is on its way out, as per the other post i made to you the other day
    The coupe...ITS ALIVE & back from the dead....again!
    The internet: where everybody knows everything about **** all.

    become a paid member:
    http://www.astraownersclub.com/vb/payments.php



  6. #6
    Status
    Offline
    adon996's Avatar
    AOC Regular
    Join Date
    Jul 2009
    Posts
    81
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cwaigy . .this is the same as mine?!?! P0100 code but have fitted 2 x new maf sensors and still now and again i get the traction control light on and engine management light on for a few seconds. . doesnt effect the performance thou.

  7. #7
    Status
    Offline
    cwaigy's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    312
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I've gone down the route of getting the earth crimp mod done in an attempt to stop this from reoccuring, but I made the mistake of getting VX to do it and I don't think they've done it right!

    Still doesn't explain why the TC light comes on though when it's an AFM fault.

  8. #8
    Status
    Offline
    drue1's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    254
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by BMAstra View Post
    I had the tc light on then the spanner with car and after a few mins the eml

    but mine was constant seems mine just gave up yesterday
    since ive had my car the car with the spanner light has been on since whats wrong with that.only problem i think i have is now and then the car will boost to 10psi then shot stright up to 20psi.other times the car boost stright to 20psi

  9. #9
    Status
    Offline
    Chris S's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    22
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by drue1 View Post
    since ive had my car the car with the spanner light has been on since whats wrong with that.only problem i think i have is now and then the car will boost to 10psi then shot stright up to 20psi.other times the car boost stright to 20psi
    any idea what causes it?

  10. #10
    Status
    Offline
    drue1's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    254
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Chris S View Post
    any idea what causes it?
    i found out my maf is showing a low reading so its on its way out

Similar Threads

  1. Replies: 3
    Last Post: 15-03-2012, 18:56
  2. regal Racelogic Traction Control & lauch control flat spot change
    By FEDZYN888 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 27
    Last Post: 28-12-2009, 08:46
  3. Replies: 1
    Last Post: 25-06-2007, 17:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •