Results 1 to 8 of 8

Thread: Astra Bertone 1.8 54 plate - Engine and TC light

  
  1. #1
    Status
    Offline
    graham_askew's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra Bertone 1.8 54 plate - Engine and TC light

    Hi there
    I have a 1.8, 54 plate Bertone.
    Few months ago I had a problem where my TC light was coming on when doing 50-60 mph with a passenger. Tracked it down that my tracking was out. Got this sorted and it didnt come back.

    But now, occationaly when I start the engine the TC light comes on and the Engine Warning light. The engine ticks over sluggishly and have really poor accelaration. But it doesnt do this every time i start the car. It hadnt done it for a month then come back recently.

    Sometimes the TC light wont be on but the Engine light is but it will run fine.

    Has anyone have/had the same problem?

    Ive read problems with air leaks, back box, sensors in the engine and wheels could be a cause but nothing definative.

    Can anyone help? I dont want to go straight to the garage and get charged a stuid amount of money and still have the problem after.

    Graham

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    do the pedal test to diagnose the fault codes

    do a search for pedal test and all will be revealed

  3. #3
    Status
    Offline
    graham_askew's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I tried the pedal test. No codes come up on the Milage display area but my Enginer Management light flashed, a code.
    it flashed 10times, 3 times, 5 times and 4 times before it remained on.
    know what it might be or where i find out what it means?

  4. #4
    Status
    Offline
    Kev.'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    9,820
    Mentioned in
    3 Post(s)
    Quoted
    7 Post(s)
    Quote Originally Posted by graham_askew View Post
    know what it might be or where i find out what it means?
    http://www.google.co.uk/search?q=Ast...ient=firefox-a

  5. #5
    Status
    Offline
    graham_askew's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers Kev.

    Ive been looking for ages. Found a few things, Ignition Coil or ECU. One guy had the same problem, changed the Ignition Coil still done the same. He was going to get his ECU looked at but the thread stopped there. Ive emailed him to find out what it was, but the thread did date back to 2005.

    I would assume (maybe wrongly) that the ignition coil shouldnt make an effect when driving. only start up?

  6. #6
    Status
    Offline
    graham_askew's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I changed the spark plugs and put some injector cleaner in and it worked for 2 weeks. But come back again last night, going to change the Coil Pack next

  7. #7
    Status
    Offline
    Fouli's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    54
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by graham_askew View Post
    I changed the spark plugs and put some injector cleaner in and it worked for 2 weeks. But come back again last night, going to change the Coil Pack next
    Hi, my astra did exactly same and the ecu were broken. I got no fault codes on but still TC light on and engine run with 3 cylinders. New ecu and programming it was about 650€ in Finland.

    Hope you get your astra sorted out.
    Astra 1.9CDTI 2006

  8. #8
    Status
    Offline
    graham_askew's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It was the coil pack. Bought a new one and swapped it over and the fault never came back.

Similar Threads

  1. Astra Bertone 1.8 54 plate - Engine and TC light
    By graham_askew in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 1
    Last Post: 05-05-2011, 22:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •