Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: time to give in i think and ask for advice

  
  1. #1
    Status
    Offline
    mullet.coupe's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    66
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Angry time to give in i think and ask for advice

    i have a astra mk4 i have been tryin to fix the problems my self since june now, cause didnt really wanna take it to vauxhall if i didnt have to. i had a front end bump, and when i took it to get diagnosed the computer wouldnt read the ecu so i got home and found out there was a pedal test so i did that and came back with 8 faults reading
    p0130 O2 Sensor Circuit Malfunction (Bank 1 Sensor 1)
    p0340 Camshaft Position Sensor Circuit Malfunction
    p0133 O2 Sensor Circuit Slow Response (Bank 1 Sensor 1)
    P0170 Fuel Trim Malfunction (Bank 1)
    P1613 SBDS Interactive Codes
    P1612 SBDS Interactive Codes
    P0130 O2 Sensor Circuit Malfunction (Bank 1 Sensor 1)
    P1555 Electronic Variable Orifice Output

    i have replaced both lambda sensors and cleaned out the throttle body and replaced the cam sensor and mass air flow sensor. and then i had my battery disconnected for a hour ( because i was told it resets the ecu) and i connected it did the peddal test and still the same 8 faults can anyone help

  2. #2
    Status
    Offline
    SRI-T Keithy's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    5,745
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    What damage did the car have in the front end bump?

    White is the new Black

    FARMYARD TUNING

    LEH IS THE FUTURE

  3. #3
    Status
    Offline
    mullet.coupe's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    66
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i was only going about 15 mph but it was a mess the front bumper, bonnet, both lights, both rads and the impact panel, ow yeh and the cross member i think its called the bar the bonnet clips into

  4. #4
    Status
    Offline
    mullet.coupe's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    66
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    B for bump

  5. #5
    Status
    Offline
    demogorgon's Avatar
    AOC Obsessed
    Join Date
    Mar 2008
    Posts
    2,534
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by mullet.coupe View Post
    i was only going about 15 mph but it was a mess the front bumper, bonnet, both lights, both rads and the impact panel, ow yeh and the cross member i think its called the bar the bonnet clips into
    i'd have said insurance job for all that.

    have you tried wiggling the lamda sensor connectors, some work their way loose. also have you disconnected the battery for 30mins then performed a pedal test once back together? it'll clear any old stored (and possible still read) faults even though they're resolved
    Men have two emotions: Hungry and Horny. If you see him without an erection, make him a sandwich

  6. #6
    Status
    Offline
    SRI-T Keithy's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    5,745
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    Give peeps a chance. it is sat night remember. Nagging want do you any favours LOL

    White is the new Black

    FARMYARD TUNING

    LEH IS THE FUTURE

  7. #7
    Status
    Offline
    Kev.'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    9,820
    Mentioned in
    3 Post(s)
    Quoted
    7 Post(s)
    the length of time for disconnecting the battery for a fault code reset will vary quite massively depending on who is replying to you. Not meaning to bag on anyone with this at all. I know demo has replied so this honestly isn't aimed at him, but from personal experience on reading about the reset, it can vary from 2mins to 24hours, to beyond & to not at all. Surely everyone can't be right. Hope you get what i'm saying.

    Perhaps buy in a cheapo fault code reader which will also reset the fault codes. If the codes come back, then they're current issues. I did this & it got shot of a couple. Some returned, a couple didn't.


    EDIT: If you do get an eBay special code reader, post up whether it shows up any fault codes just out of interest.
    I got a code reader & it shows no codes
    Took the car to a garage & it shows no codes.
    Did the pedal test & i've 4 codes.
    No EML light.

    Wonder which to believe.

  8. #8
    Status
    Offline
    mullet.coupe's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    66
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok thanks for all ur info guys my battery has been disconneced since 7 so gonna leave it till tomoz and then see what faults there are. and i cant use one ov them code readers because when i put it in to read the faults it wont even bring the code reader on. and thats what makes me think the ecu myt be (dead) thanks again i will post tomoz too show what the out come was

  9. #9
    Status
    Offline
    mullet.coupe's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    66
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i have just put my battery back on and took my car for a spin still runnin in limp mode and its came up with 8 faults again reading
    p0130
    p0340
    p0134
    p0170
    p1613
    p1612
    p1555
    p0140

    so i dont no what it can be has any one got any ideas will be much appreciated thanks

  10. #10
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have u got a spare key u can try?

    or at least just the transponder part?

    random suggestion so bear with me!!!!


    as for disconnecting the battery to clear codes - i always just unplug the 2 big plugs on the ECU for 10mins or so - so much quicker than the battery etc

Page 1 of 3 123 LastLast

Similar Threads

  1. Is it time to give up??
    By benp16 in forum Astra Discussion & Chat
    Replies: 6
    Last Post: 17-02-2012, 16:12
  2. A pic that BYRON took - time to give the game away
    By Skuzzle in forum Astra Discussion & Chat
    Replies: 15
    Last Post: 11-08-2004, 13:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •