Results 1 to 8 of 8

Thread: changing a speedo cable

  
  1. #1
    Status
    Offline
    3dj's Avatar
    AOC Newbie
    Join Date
    Jun 2009
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    changing a speedo cable

    how do i locate my speedo cable on a astra i.6 8 valve (on a 53 plate).
    and are they hard to change.

    i've had a scraping noise coming from the front for some time. thought it was the brakes, but checked those.

    anyway, my speedo packed in today, after i heard some bad crunching noises. so i take it that was the problem.

    any help would be appreciated. cheers

  2. #2
    Status
    Offline
    rob16v's Avatar
    AOC Fanatic
    Join Date
    Oct 2008
    Location
    Saffron Walden, United Kingdom
    Posts
    681
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    i think u dnt have a speedo cable, it should be fly by wire, but im not 100% on the 8 valve


  3. #3
    Status
    Offline
    3dj's Avatar
    AOC Newbie
    Join Date
    Jun 2009
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i thought that after i put the first post on.

    the scraping noise is probably something else. (seems to be worse when i'm turning right).
    i've stripped the brakes. made sure nothing is rubbing/catching on the discs, but still getting the noise. i thought it might be a wheel bearing but at 70/80 mph it's dead quiet.

  4. #4
    Status
    Offline
    rob16v's Avatar
    AOC Fanatic
    Join Date
    Oct 2008
    Location
    Saffron Walden, United Kingdom
    Posts
    681
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    check ur throttle body thats the easiest way if theres no cable then its fly by wire, also ur scraping cud be cv joint? powersteering? just guessin lol i aint a mechanic


  5. #5
    Status
    Offline
    3dj's Avatar
    AOC Newbie
    Join Date
    Jun 2009
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i'll have a look. cheers

  6. #6
    Status
    Offline
    3dj's Avatar
    AOC Newbie
    Join Date
    Jun 2009
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    got the speedo going. think it was a bad connection.

    that grating noise is bothering me though. seems to car worse when the cars warmed up a bit. also can hear it when i put the brakes on. it's also doing it when i turn left and right now.

  7. #7
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    Mk4 speedo is all electronic, no cables involved.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

  8. #8
    Status
    Offline
    rob16v's Avatar
    AOC Fanatic
    Join Date
    Oct 2008
    Location
    Saffron Walden, United Kingdom
    Posts
    681
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by 3dj View Post
    got the speedo going. think it was a bad connection.

    that grating noise is bothering me though. seems to car worse when the cars warmed up a bit. also can hear it when i put the brakes on. it's also doing it when i turn left and right now.
    maybe u need new discs and pads?


Similar Threads

  1. Speedo Cable
    By graboy in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 07-01-2011, 20:56
  2. Speedo cable
    By Mitch in forum Electrical
    Replies: 2
    Last Post: 14-02-2008, 19:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •