Results 1 to 8 of 8

Thread: Traction control and abs light-newbie

  
  1. #1
    Status
    Offline
    Wisam H's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Traction control and abs light-newbie

    Hi all, i was wondering how to fix the traction control and the abs light as it is always on?

  2. #2
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    If it's always on you probably have a faulty ABS sensor on your front passenger side wheel hub.
    Only cure is to replace the complete hub, there are no seperate parts available.
    Get a pattern part (SKF brand) one off a motor factors or ebay, much cheaper than buying the same part off Vauxhall.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

  3. #3
    Status
    Offline
    Wisam H's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    a month ago it used to only turn on when i hit the pedal hard and would stay on for roughly 15min and turn off but now its always on

  4. #4
    Status
    Offline
    JC Jam's Avatar
    AOC Regular
    Join Date
    Sep 2008
    Posts
    202
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had the same. as SQ Man said. You need a new front hub. get one off ebay for £60 ish and does cost alot to fit at local garage, or do it yourself.
    Astra Cabby Turbo

  5. #5
    Status
    Offline
    Wisam H's Avatar
    AOC Newbie
    Join Date
    Oct 2009
    Posts
    17
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok thanks for quick reply, i will get a new one as soon as possible

  6. #6
    Status
    Offline
    danboi2's Avatar
    AOC Newbie
    Join Date
    Feb 2007
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by SQ Man View Post
    If it's always on you probably have a faulty ABS sensor on your front passenger side wheel hub.
    Only cure is to replace the complete hub, there are no seperate parts available.
    Get a pattern part (SKF brand) one off a motor factors or ebay, much cheaper than buying the same part off Vauxhall.
    Hi ive got the same problem was told by vauxhall it was the drivers side, just woundering why you said it was the passenger side one many thanks

  7. #7
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    Passenger side front hub sensor supplies pulse for ABS, TC & speedo, plus it is also the one that takes most abuse on the road from potholes, etc. so seems to be the one that fails the most.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

  8. #8
    Status
    Offline
    danboi2's Avatar
    AOC Newbie
    Join Date
    Feb 2007
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks mate much appreciated

Similar Threads

  1. 2004 zafira A - 1.8 A/T: Engine check light and Traction control light ON
    By cbcnestormn in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 06-04-2010, 15:27
  2. Replies: 9
    Last Post: 25-03-2010, 19:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •