Results 1 to 6 of 6

Thread: Air Bag Light after fitting Amp

  
  1. #1
    Status
    Offline
    Bubba's Avatar
    AOC Obsessed
    Join Date
    Feb 2007
    Posts
    3,729
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Air Bag Light after fitting Amp

    Hey

    Finally got round to fitting my amp today, everything went OK apart from my air bag light is now on.

    Only things I can think of is that i disturbed one of the side impact air bag sensors, I have stripped the doors down again and checked all connections and they seemed fine.

    The other thing is my earthing point, I earthed onto one of the screws holding the passengers air bag in the glovebox, from what I could see this makes contact with the chassis of the car so seemed like a good choice, could this be causing my air bag light to come on?

    I have tried taking this screw out and the air bag light still comes on. When I start my car the air bag light goes off, then about 5 seconds later comes back on.

    Worst case scenario is I damaged some of the wiring going to the door as I had to use a coat hanger to feed the speaker cable through the OE wiring, I put some tape on the end of the coat hanger before feeding it through to make sure it didn't catch any of the cables and damage them.

    I may have already fixed the problem and just have to get the light reset but thought I would check on here first.

    Thanks for any help.

  2. #2
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    Did you have the ignition on when doing anything with the wiring?
    If so, that may have triggered the airbag light.
    To get the light turned off you will need someone with Tech2 or a code reader to reset it for you.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

  3. #3
    Status
    Offline
    Bubba's Avatar
    AOC Obsessed
    Join Date
    Feb 2007
    Posts
    3,729
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by SQ Man View Post
    Did you have the ignition on when doing anything with the wiring?
    If so, that may have triggered the airbag light.
    To get the light turned off you will need someone with Tech2 or a code reader to reset it for you.
    I did turn the ignition on a couple of times with the doors stripped to test the amp/speakers so this might be the cause. Will my earth point be OK? I don't want to take my car to a garage and pay them to reset it just for it to come on again because of how its wired up.

    Thanks for the reply.

  4. #4
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    The airbag bolt is literally just holding the airbag in place so it doesn;t jump out the dash when it goes off. It won;t be causing the issue

    If you had any of the sensors or unplugged with side inpact airbags the battery needs to be disconected to stop the light coming on
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  5. #5
    Status
    Offline
    Bubba's Avatar
    AOC Obsessed
    Join Date
    Feb 2007
    Posts
    3,729
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    £10 later and its all sorted. Turns out i must have had both sensors disconnected at some point with the igniton in (doh) just needed reset and its all fine now. Thanks for the help.

  6. #6
    Status
    Offline
    SQ Man's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    4,881
    Mentioned in
    0 Post(s)
    Quoted
    2 Post(s)
    If you had the front door plugs off that would have disconnected the side airbag sensors.
    2003 Sapphire Black 3Dr DTi Astra
    Custom Irmscher kit, Interior Leather/Alcantara retrim & Alpine/Focal Install
    Install progress (----------)

Similar Threads

  1. weird after fitting front mounted intercooler... fan light and engine warning light
    By Danithesqaudy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 04-02-2011, 14:49
  2. Help! Engine light on and Traction control light after fitting VXR turbo to GSI
    By danielle-gsi in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 22-01-2010, 01:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •