Results 1 to 5 of 5

Thread: Cam Cover and Lambda Sensor

  
  1. #1
    Status
    Offline
    Will2k1's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    845
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Cam Cover and Lambda Sensor

    Firstly, since owning my coupe turbo I have had to replace the cam cover gasket twice. The first time was because it needed it from the previous owner but I forgot the 10 o rings and it started leaking again. So I replaced it again with the o rings this time and took lots of care to get it right including going from inside outwards. Yet I've just noticed that it has stared to leak again. Is there something I am doing wrong? The leak is at the passenger side front of the cam cover.

    Secondly, I've managed to melt or snap my rear / post-cat lambda sensor and so it needs replacing. Just wandering if anybody knows a cheaper place for this? So far I have found http://cgi.ebay.co.uk/Rear-Lambda-Se...d=p3286.c0.m14 which is less than £70 delivered.

    Thanks in advance.
    Black Astra Coupe Turbo

  2. #2
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Thats a good price for a bosch one mate.

  3. #3
    Status
    Offline
    Will2k1's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    845
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I may be ordering one soon then if nobody else has anything to say on that.

    Anybody know about my cam cover leaking?
    Black Astra Coupe Turbo

  4. #4
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thats where mine was leaking but has stopped since replacing gasket, did you check if theres any damage to the head or cam cover at that point, could be possible

  5. #5
    Status
    Offline
    Will2k1's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    845
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I didnt check the head, but I cleaned and made sure the cam cover is okay.

    I may not have cleaned off all of the old gasket, but would that cause this problem?
    Black Astra Coupe Turbo

Similar Threads

  1. lambda sensor
    By dp88 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 18-06-2011, 21:13
  2. Lambda Sensor
    By DougSmith in forum Electrical
    Replies: 1
    Last Post: 04-03-2005, 16:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •