Results 1 to 3 of 3

Thread: AFL headlights from hell!

  
  1. #1
    Status
    Offline
    Capo79's Avatar
    AOC Regular
    Join Date
    Sep 2007
    Posts
    80
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    AFL headlights from hell!

    Was in an accident last March, which among other things resulted in a new right hand side headlamp. The car is fitted with AFL bi-xenon.

    A few weeks ago, after having washed the car with a high pressure washer, the AFL warning light showed up on the dash. It's the warning light that indicates that the turning function of the headlamp isn't working. I also noticed a lot of vapour inside the headlamp, in other words water had gotten inside the cover somehow (I also found a bug in there!). Immidiately after I noticed the warning light, I pulled over and looked at the lights. The new lamp projector was turned all the way to the right. A minute after, it shut down and the fog lights turned on as this is a saftety mechanism on the car.

    Anyway, talked to the insurance company, and had the workshop that swapped the lamp in the first place to get a new one. So they did today. What I noticed though, was that both the ballast and the "swing controller" box-thingy had to be swapped over from the seemingly damaged headlamp over to the new one. As I suspected, the new headlamp did't do much better. The warning light is still flashing in the dash! Even though the ECU was reset, it's still flashing.

    I don't know why, but the lamps won't adjust like they normally do when the ignition is turned on. That might just be a consequence of the mentioned fault.

    What is this?? Is it the controller box, or what? I'm also a bit baffled over the fact that there isn't any fault codes displayed when I've done the pedal test. Unfortunately, as this isn't an Opel shop, they don't have tech2, so I haven't yet been able to see if there really is a fault code present. Even so, I've seen from the exhaustive canbus fault code listing on this forum, that codes for these kinds of faults exists...

    Another thing I've noticed is that the warning light is flashing. According to the instruction booklet, I've gotten the impression that any fault would have that warning light illuminate constantly. Further, it says that it will flash four times if you have set the headlamps on a so-called symmetric mode (should be done if driven e.g in the UK).

    So.... WTF?!?! Anyone with any idea of what the .... this is? I'm pretty fed up with it allready. I'm thinking either the controller box or a simple fuse. Want to check the latter, but don't know where that fuse might be located.

    The work shop said that they will try to help me with this issue, but I'm a natural sceptic and won't take that for granted. Want to see if I can help myself out of this potentially expensive mess (the lamp itself cost the insurance company more than 2000 euros!!)

    Thanks for any help!
    2005 Opel Astra 2.0 Turbo 170 bhp
    2005 Yamaha FZ6 - 98 bhp 0-100 in 3,2
    http://img102.imageshack.us/img102/6...5405911uq6.jpg

  2. #2
    Status
    Offline
    blackbirdxx's Avatar
    AOC Regular
    Join Date
    Apr 2009
    Posts
    258
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I would just take the car back and insist to get it fixed. Not your problem how if the insurance is paying.
    I am shure it needs to be tech 2 and the lights needs to be reset. A normal code reader wont do it, so thats a trip to vauxhall or opel in your case

  3. #3
    Status
    Offline
    Capo79's Avatar
    AOC Regular
    Join Date
    Sep 2007
    Posts
    80
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the reply!

    Yes, I've been thinking about having it tech 2'ed also. Actually, I talked to the guy at the workshop about it. He had suddenly remembered that they had to do that the first time they changed the lamp... So i guess that's the solution to it. Hopefully...
    2005 Opel Astra 2.0 Turbo 170 bhp
    2005 Yamaha FZ6 - 98 bhp 0-100 in 3,2
    http://img102.imageshack.us/img102/6...5405911uq6.jpg

Similar Threads

  1. what the hell? Help?
    By stumpy1505 in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 13-11-2011, 17:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •