Page 1 of 5 12345 LastLast
Results 1 to 10 of 47

Thread: Any idea's guys, p0170

  
  1. #1
    Status
    Offline
    bereet's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    878
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Any idea's guys, p0170

    Bout 3 weeks ago my car started playing up, smelling of petrol, running abit poo etc, thought it was down to the afm which I was changing (vxr one) when I went red dot, while at Red Dot they said my car massivly over fuelling, after the vxr afm and injectors were fitted.

    So they backed the fueling off abit and was ok but he said it is still over fuelling a little abit.

    It was spluttering slightly after dot but on way home went ok and ran perfect, half way home the emmissions light came on but still ran perfect without spluttering.

    When I got home I got P0170, fuel trim blank 1, I reset the ecu and the light stayed off but smelled of petrol and spluttered again, now tonight the light has come on and stopped spluttering lol, can anyone tell me what might be the problem with this P0170 code, We have an idea that it might be the front O2 sensor as when the pre cat was put on it had seen better days but is there any other things this may be?

    Cheers in advance,

    Mike
    SILVER ASTRA GSI RUNNING . . . . . . . HA HA THAT WOULD BE TELLING

  2. #2
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    I had that fault code and it was the exhaust sensors, I changed both though. It can also relate to the AFM but you said thats a new one so its not that. If your mates got a decent fault code reader see if you can see the voltages on the o2 sensors, If they stay constant on any of them when the engine is hot then that sensor is at fault.

  3. #3
    Status
    Offline
    kn51's Avatar
    AOC Regular
    Join Date
    Sep 2008
    Posts
    97
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i have the same problem on mine please could you let me know how you get on

  4. #4
    Status
    Offline
    bereet's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    878
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Coupe John View Post
    I had that fault code and it was the exhaust sensors, I changed both though. It can also relate to the AFM but you said thats a new one so its not that. If your mates got a decent fault code reader see if you can see the voltages on the o2 sensors, If they stay constant on any of them when the engine is hot then that sensor is at fault.
    Would this fault cause the car to over fuel John? I'll probably do the front O2 sensor like Vauxtilidie told me and see how I get on.
    SILVER ASTRA GSI RUNNING . . . . . . . HA HA THAT WOULD BE TELLING

  5. #5
    Status
    Offline
    bereet's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    878
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by kn51 View Post
    i have the same problem on mine please could you let me know how you get on
    Yeah will do m8
    SILVER ASTRA GSI RUNNING . . . . . . . HA HA THAT WOULD BE TELLING

  6. #6
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    AFM and o2 sensors are most important for the fueling mate, if you have a bad o2 sensors then it could run lean or rich, would run like poo with a bad one. you don' have an exhaust leaks do you?

  7. #7
    Status
    Offline
    bereet's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    878
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Not that I know of m8, not blowing or anything like that, ok well I'll do the O2 sendor first and hopefully will be reet, if not I'll move onto the next one and so
    SILVER ASTRA GSI RUNNING . . . . . . . HA HA THAT WOULD BE TELLING

  8. #8
    Status
    Offline
    vauxtillidie's Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    690
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    no exhaust leaks as far as we know, mike we'll try my sensor on it tmoz
    2006 Astra VXR, Flame Red, 19's, AFL, Cruise Control, CD70 + Aux in, CID, Bluetooth, Powerfold Mirrors, DDS/TPMS, Sight & Light, Check Control, Speed Locking

  9. #9
    Status
    Offline
    bereet's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    878
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok Chris, you'll have to let me know when tomorrow m8, I dont finish til 5 :-(
    SILVER ASTRA GSI RUNNING . . . . . . . HA HA THAT WOULD BE TELLING

  10. #10
    Status
    Offline
    vauxtillidie's Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    690
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    no probs call round after work u can use it for a few days]
    2006 Astra VXR, Flame Red, 19's, AFL, Cruise Control, CD70 + Aux in, CID, Bluetooth, Powerfold Mirrors, DDS/TPMS, Sight & Light, Check Control, Speed Locking

Page 1 of 5 12345 LastLast

Similar Threads

  1. need some idea's guys... (alloys)
    By C9SRi in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 18-11-2005, 10:51
  2. Guys Guys Guys.. quick question
    By Skuzzle in forum Astra Discussion & Chat
    Replies: 85
    Last Post: 15-01-2005, 01:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •