Results 1 to 10 of 10

Thread: help needed ?

  
  1. #1
    Status
    Offline
    LOCKO's Avatar
    South Central RO
    Moderator
    Join Date
    Feb 2008
    Location
    hampshire
    Posts
    8,862
    Mentioned in
    28 Post(s)
    Quoted
    23 Post(s)

    help needed ?

    late last night was coming back from gf's doing around 55mph with cruise control on and all of a sudden traction light comes on and stays on and the car just decided it wont rev so came to a stand still turned engine off and back on again light goes out and car revs and pulls like a train again

    any ideas what may of caused this

    didnt risk bringing the car to work this mornin

    please help as im coompletely baffled

    cheers ryan

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have u done the earth crimp mod? if not do it asap

    i used to get the TC light on mine very regularly - did the mod and its never came on since!

    details here: http://www.astraownersclub.com/vb/sh...d.php?t=117185

    what about the pedal test? it could be the AFM but usually its coupled with the car/spanner light.....still could be the earth though, as it can trigger various random "phantom" faults

  3. #3
    Status
    Offline
    LOCKO's Avatar
    South Central RO
    Moderator
    Join Date
    Feb 2008
    Location
    hampshire
    Posts
    8,862
    Mentioned in
    28 Post(s)
    Quoted
    23 Post(s)
    didnt try pedal test mate as was 12:45 this mornin ,was just happy to get home

    i never noticed the eml come on but it might of ,will try pedal test this evening

    have printed the earth mod so will have a go at that to

    any other thoughts peeps

  4. #4
    Status
    Offline
    Smoki333's Avatar
    AOC Fanatic
    Join Date
    May 2009
    Posts
    534
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had this happen to me the other week, cruise control on @ 70 for a couple miles and then all of a sudden car just starts running lumpy (dont acceleratoring) an slowing dieing.
    I pulled over,try turnover an it just runs lumpy and dies so check EVERYTHING in engine bay, nothing loose,leaking or burning.
    Give it a couple mins, then it starts up first time and goes like the clapper from then on!

    I cant remember the fault code for the life of me! but its something to do with the cruise control reading constant and something happens.

    When im on cruise control now i make sure to give it a blip now an then so it reads a different speed an its been fine.

    There must be a cure though.

  5. #5
    Status
    Offline
    Smoki333's Avatar
    AOC Fanatic
    Join Date
    May 2009
    Posts
    534
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ah here you go mate! Are you running your DV on its own (one way valve)? i am and i think thats the problem at a constant speed the ecu thinks there is a boost leak so the Traction light comes up, which happen to me so next time im on the motorway im gona try run both OEM and DV together and see if that helps.

    This is taken from another thread:

    Quote Originally Posted by 2fast View Post
    UPDATE!

    It isnt the MAF sensor, I tried with the brand new from my friend, but it is all the same.

    But I think that I have an idea...

    The situation is like this, when I clear the fault code the car is going fine if I do not go on the freeway and drive at a constant speed. If I drive on "normal" roads and accelerate all the time (you know what I mean, you accelerate a bit, then you brake... etc...) the car is OK, and it goes fine all the time.

    Could it be that the blow off valve is cause of this problem, because, when I drive on the freeway at a constant speed, above 120 km/h I can hear the BOV passing air out all the time (especially if i put it on cruise control).
    Could it be that the ECU registers that as a boost leak (because it realy is leaking boost) and because of that it throws up the P0170 fault code?

    I tested the car the other day on normal roads, and it was going fine, today I went on a little trip on the freeway, the car was running fine until we got on the freeway and drove at a constant speed (with the BOV hissing all the time). After that I noticed that the car registered a fault code because it wouldnt boost as it should (up to 1.5bar overboost, and hold at 1.1 - EDS Phase 3). It would only go up to 0.8 bar or something.
    Full thread here:

    http://www.astraownersclub.com/vb/sh...+control+fault

  6. #6
    Status
    Offline
    LOCKO's Avatar
    South Central RO
    Moderator
    Join Date
    Feb 2008
    Location
    hampshire
    Posts
    8,862
    Mentioned in
    28 Post(s)
    Quoted
    23 Post(s)
    yes baileys is running on its own ,oe has the spacer in it but its been like that for 18 months
    and never had this before
    im now not sure as i was going up a hill about 10% incline so cc was accelerating
    for me it was when i got to top of hill that it decided to die and throw the tc light on

    bloody cars will have a good look tonight and see if it does it again

    cheers for that smoki333

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    well ive never used the one way valve - and TC appeared when running aftermarket DV and even when not using one

    doing the earth mod 100% cured my problem and has never appeared since (did it about 6months ago and used to appear ever other day!)

  8. #8
    Status
    Offline
    Smoki333's Avatar
    AOC Fanatic
    Join Date
    May 2009
    Posts
    534
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Might give the earth mod ago myself.

  9. #9
    Status
    Offline
    rhys57's Avatar
    AOC Obsessed
    Join Date
    Apr 2005
    Posts
    2,348
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What does the earth mod do then?
    Vxr turbo with 360 bearing and twin oils seals & Evoms dv. Cdti airbox 63mm tophat.Milltex cat back and pre cat.. Regal 245 leh phase 1 ipf remap.Whiteline rarb.

  10. #10
    Status
    Offline
    Smoki333's Avatar
    AOC Fanatic
    Join Date
    May 2009
    Posts
    534
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by rhys57 View Post
    What does the earth mod do then?
    Im guessing its this:

    http://www.astraownersclub.com/vb/sh...ighlight=earth

    But can cure a whole host of problems.

Similar Threads

  1. help needed with bodykit (photoshop needed)
    By pog in forum Bodywork and Exterior
    Replies: 3
    Last Post: 25-02-2009, 19:05
  2. Tools needed to lower front of my cab - help needed
    By paulocardyo in forum Astra Discussion & Chat
    Replies: 6
    Last Post: 04-06-2008, 20:49
  3. New Laptop needed, spec advise needed please
    By Sausages in forum Chit Chat and a Warm Welcome!
    Replies: 23
    Last Post: 22-01-2008, 10:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •