Results 1 to 4 of 4

Thread: speedo problems

  
  1. #1
    Status
    Offline
    giggzy345's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    speedo problems

    hi everyone,im hoping somebody can help me,ive got a astra on a 51 plate and the problem is that my speedo has completly gone down,all my other dials are fine just the speedo,can anyone point me in the right direction for the fix any help would be apprecated,thanks in advance

  2. #2
    Status
    Offline
    Big Col's Avatar
    AOC Fanatic
    Join Date
    Feb 2004
    Posts
    438
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    speedo takes its signal from a sensor in the front passenger side hub. Check/clean/reseat the connection to this sensor would be my starting point.
    Vauxhall history - 13S | 14NV | C16XE | X20XEV

  3. #3
    Status
    Offline
    giggzy345's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks i will have a look at that in the morning,thanks agin

  4. #4
    Status
    Offline
    mzungu1986's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if you have recently fitted a aftermarket sterio than can affect it as i found out after spending 100 pound

Similar Threads

  1. mk4 dti speedo +other problems.
    By rickyb in forum Electrical
    Replies: 7
    Last Post: 10-03-2012, 22:54
  2. Speedo problems
    By M4th3m4t1kz in forum Astra Discussion & Chat
    Replies: 7
    Last Post: 19-07-2009, 20:49
  3. Speedo problems
    By B4SH in forum Interior
    Replies: 4
    Last Post: 09-07-2007, 23:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •