Results 1 to 6 of 6

Thread: Fuel filter change. Now won't start.

  
  1. #1
    Status
    Offline
    Saulty's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    51
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Fuel filter change. Now won't start.

    I have just changed the fuel filter on my Astravan 1.7 CDTI and now it won't start!
    It is a 54 plate MK4 with the Z17DTL engine.
    I had look in the fuel filter after about ten minutes of trying to start and it is still dry in there!
    I have read on here about a spring in the housing, the only spring mine has is a small one on the cover of the housing.
    Have I lost a spring and would it stop it from running?
    Thanks.
    Matt.

  2. #2
    Status
    Offline
    KevT.'s Avatar
    Yorkshire RO
    Join Date
    Jul 2005
    Location
    Bradford
    Posts
    9,218
    Mentioned in
    7 Post(s)
    Quoted
    15 Post(s)
    take the top back off and fill the filter housing up with fuel then it should fire no bother and when it does fire keep some revs on for a coupel of mins then leave the car running for 15 mins or take it for a quick spin, this is let the fuel go throght the pump enough to take any air out.

    i had the problem with mine not starting when i did the filter change for the first time but when i did it a year later i filled the filter housing up and first first time and had no bother at all!

    AOC top 15 car at PVS 2009 & 2010
    313.7bhp/343Ibft


  3. #3
    Status
    Offline
    Saulty's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    51
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks Kev.

    Have I lost a spring or is that the one on the top of the housing?

  4. #4
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Dont drive it, fill the filter to the top and start it and let it just idle for 15minutes like mentioned. Jobs done.

  5. #5
    Status
    Offline
    Saulty's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    51
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Did as you both said and it started after a few goes.

    Been on a 135 mile round trip no bother!

    Thanks for your help guys.

  6. #6
    Status
    Offline
    KevT.'s Avatar
    Yorkshire RO
    Join Date
    Jul 2005
    Location
    Bradford
    Posts
    9,218
    Mentioned in
    7 Post(s)
    Quoted
    15 Post(s)
    woudnt do any harm driving it once its been running for a few minutes.

    No you aint lost any springs, there is just the very small one in the filter housing top.

    AOC top 15 car at PVS 2009 & 2010
    313.7bhp/343Ibft


Similar Threads

  1. No start after fuel filter change -
    By Jontymk in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 16-01-2011, 17:05
  2. diesel fuel filter change slow start
    By scouceget1 in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 29-06-2008, 11:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •