Results 1 to 8 of 8

Thread: engine light!!!!!!!!!!!!!!!!

  
  1. #1
    Status
    Offline
    leevaux's Avatar
    AOC Newbie
    Join Date
    Jul 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    engine light!!!!!!!!!!!!!!!!

    Hi All
    I Have a 2001 zafira 1.6 amongst other Vaxhalls!! which has been great but doing 60mph the other day the engine light came on and it went into limp mode pulled over did the on off ignition thing and it got me home it did the same the next day been to my local garage they plugged in and said they could find nothing we would have to change different parts until it was solved this could work out very expensive so do the more tech minded out ther have any clues i no with out a code you are probley p---ing in the wind i may have to take some ware else cheers guys and gals

    Lee

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    if the light has come on there should be a fault code stored which if the garage had a decent code reader should have pulled up a code. has the car got any other symptoms or driveability problems, a buggered Egr can often bring EM light on when you are cruising at speed. post back with more symptoms and some other good folk may be able to help too

  3. #3
    Status
    Offline
    Enigma ???'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,468
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    This could be absolutely anything no code no symptoms its impossible

  4. #4
    Status
    Offline
    leevaux's Avatar
    AOC Newbie
    Join Date
    Jul 2009
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    engine light!!!!!!!!!!!!!!!

    Hi Guys and gals
    Just been out in the Zafira again starts fine runs fine all as it should came of a roundabout put my foot to the floor to get up to speed and the light came on pulled over did the key thing drove home 5 mins no problem garage recons their is no code stored i will take it back tommorow.
    Lee

  5. #5
    Status
    Offline
    Enigma ???'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,468
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As soon as the light comes on take it to the garage with the light on don't turn it off as they said the ECU does not store all codes but with the light on the tech 2 will see the code that is their

  6. #6
    Status
    Offline
    oblong1's Avatar
    AOC Newbie
    Join Date
    Jul 2009
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi All - sorry to add to a current thread, but I am facing a similar problem.
    I Have a 2003 Astra 1.6 SXi, when driving home via motorways yesterday (above 60mph) the engine light came on and it went into limp mode. I pulled over and did the on/off ignition thing and it got me further and eventually home (after 5 stop/starts).
    I have been to my local garage and they say that there is an ECU fault (didn't give the code) but basically the jist was that if it continues, I will need another ECU and that would cost upwards of £1000. Is this the case?
    Or is there a second hand one I could find and have programmed for a much lesser amount (ie, £350?)

    Any advice/info would be appreciated.

    oblong1

  7. #7
    Status
    Offline
    Enigma ???'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,468
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Take it to another garage crazy times at the mo make people act crazy queue the sound ca..ching! ££££££££££££

  8. #8
    Status
    Offline
    Aous's Avatar
    AOC Fanatic
    Join Date
    Jan 2009
    Posts
    464
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    One thing to try is to disconnect the negative on the battery over night. This effectively resets the ECU and will clear any stored faults. The engine also goes into a learning mode again and will recalibrate all of its sensors. If there is still a light after this, there is certainly a fault. The code should be retrievable using the standard methods.

    You can pay VX £40 to look at it properly with the Tech2 and then replace the faulty sensor yourself (most are fairly easy to do).

    Be aware that if your D/C the battery, if you have a stock radio, it will be reset requiring the unlock code. Your clock will also need setting again....

Similar Threads

  1. weird after fitting front mounted intercooler... fan light and engine warning light
    By Danithesqaudy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 04-02-2011, 14:49
  2. 2004 zafira A - 1.8 A/T: Engine check light and Traction control light ON
    By cbcnestormn in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 06-04-2010, 15:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •