Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: z20let sump pan questions

  
  1. #1
    Status
    Offline
    inmyvain's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    3,705
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    z20let sump pan questions

    just had the lower sump pan off on my gsi to see if theres any nasty crap in there blocking the pickup screen etc and everythings pretty clear....
    im still getting a strange light knocking sound when the engines turning over?!?
    if the oil pump is on the way out does it make this sort of sound?
    another question i have is if the silver canister/sensor fixed to the bottom of the sump is just for the oil level?
    .....also how low will the oil go before the low oil level triggers on the mfd?

  2. #2
    Status
    Offline
    inmyvain's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    3,705
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    appreciate anyone knowledge on any of this,
    thanks.

  3. #3
    Status
    Offline
    inmyvain's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    3,705
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i have a pressurized crankcase which is probably why im getting the noise... could the the pcv valve be the cause....i will have to check the breather pipes tomorrow for blockages...can see it being somthing as simple as this though...could it be the pcv valve has failed??

  4. #4
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If your crankcase if pressurised then the most likley cause will be the wee one way valve on the breather from the cam cover to the inlet mani.

    A pressurised crankcase will also limit the return of oil from most parts of the engine making the oil pump work harder.
    Astra SRi Turbo
    281|317

  5. #5
    Status
    Offline
    inmyvain's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    3,705
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks my man,im gonna check in a bit see what i come up with.....maybe a clean will doo or a replacement...
    a new valve cant be too expensive....
    anybody got a part number for it?

  6. #6
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Part No. 9201848, around £15 plus vat from VX.

    Many people just use a one way valve from halfords as they are cheaper.

  7. #7
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You could just take it off if you wanted

  8. #8
    Status
    Offline
    inmyvain's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    3,705
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it was pretty gunged i cleaned it through but it seems to be letting air through both ways........so think its probably had its day!

    nyzrox do u mean can run ok without anything in place of the valve??
    so just use a joiner and run it straight to tb??
    i thought about a catch tank but is that a waste of money??
    cheers for help so far

  9. #9
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Na, just disconnect and plug them mate, don't join them together as you'd be in the same situation again

    I'd be getting a one way valve tho, that breathers there for a reason, i know it probably doesn't need to be but meh...
    Astra SRi Turbo
    281|317

  10. #10
    Status
    Offline
    mattjk's Avatar
    AOC Fanatic
    Join Date
    Nov 2008
    Posts
    593
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mines unplugged along with the main one no problems here. Although when I took the main one off it was gunged up with tar.

Page 1 of 2 12 LastLast

Similar Threads

  1. Exhaust and oil sump questions...
    By Amr in forum Astra Discussion & Chat
    Replies: 9
    Last Post: 12-01-2011, 15:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •