Results 1 to 8 of 8

Thread: What features a broken turbo?

  
  1. #1
    Status
    Offline
    c20let2k's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    415
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    What features a broken turbo?

    Wondering what the best way to check if my turbo is gone pop?

    I have no blue smoke, it's a little oil inn the pipework from the intercooler..
    No bad sounds or something like that..

    But my problem is that i only get 13psi at about 33-3500rpm and falls down to about 8psi as the rpm passing 4k rpm, and it holds 8psi to 7400rpm.

    Running phaze 2..

    Thanks

  2. #2
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If your loosing boost higher up the rev range then it's more than likley the actuator.

    I the turbo is making boost then it's fine (as long as it's not smoking, ect.. ect..) it can't be broken and still make boost.
    Astra SRi Turbo
    281|317

  3. #3
    Status
    Offline
    c20let2k's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    415
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sometimes i altso have a unstabile boost, goes between 7psi and 10 psi before it goes up to 13psi than fall down again..

    Is it normal with a little oil in the pipework?
    No smoke or bad sounds..

  4. #4
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah, deffinetly the actuator mate.

    I assume you've chenged the Boost Control Solenoid's?, if not i'd change them at the same time
    Astra SRi Turbo
    281|317

  5. #5
    Status
    Offline
    c20let2k's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    415
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Haven't change anything yet..

    But i tried to adjust the actulatorbolt today, little change if i tighted it up, tried more and more and little change..

    Still just the actulator that's gone?

  6. #6
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yes, i had the same problem, tightening the actuator made no difference so i changed it and it's been fine since, i think its something to do with the spring becoming weak
    Astra SRi Turbo
    281|317

  7. #7
    Status
    Offline
    c20let2k's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    415
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    So i just change the actulator and it may be fine again?

    Thinking about buying a reinforced actulator from courtenaysports for 129 gbp..

  8. #8
    Status
    Offline
    c20let2k's Avatar
    AOC Fanatic
    Join Date
    Dec 2008
    Posts
    415
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Have now tested pulling of the hore that goes from the boost controller to the actulator, and it doest'n boost anymore now than it did before..

    My turbo that's broken now or is it steel the actulator??

Similar Threads

  1. Broken turbo
    By Quickbricky in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 31-08-2011, 12:56
  2. Is this a 'broken' turbo
    By flipcjl in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 09-02-2007, 18:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •