Results 1 to 6 of 6

Thread: Lumpy idle and dodgy coolant temp sensor?

  
  1. #1
    Status
    Offline
    Iain L's Avatar
    AOC Newbie
    Join Date
    Jan 2006
    Posts
    16
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Lumpy idle and dodgy coolant temp sensor?

    Last weekend my coolant temp sensor went a bit funny, reading very odd. Yesterday my idle started to go a bit lumpy too, and today, idled bad and then, cut out.
    EML light comes on then goes, but the spanner light is now on all the time.

    Could these 2 things be connected or just coincidental?

    Can anybody tell me how to fix my problems?

    Thanks.

  2. #2
    Status
    Offline
    Dannywrc's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,062
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had exactly the same with my mk3, it got really bad though, i thought there was some major engine problems . put it on the computer and it was a damaged temp sensor. replaced it and everything was fine.

  3. #3
    Status
    Offline
    smarty-turbo's Avatar
    AOC Fanatic
    Join Date
    Dec 2007
    Posts
    336
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be a earth fault mate i had same problem and i had to run a extra earth link in but it solved the problem
    search on here earth mod try that

  4. #4
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Duff temp sensor will cause a crap idle etc, so change it to see if it cures your problems, the sensor is only about £15.

  5. #5
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what does the pedal test actually bring up?

    CTS is less than a tenner on ebay and very quick postage ive found in the past

    id also highly recommend doing the earth crimp mod tho - its worked a treat on mine and no longer brings up duff warning lights.

  6. #6
    Status
    Offline
    kellybabe's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    can anybody please tell me where i will find the temp sensor on an astra 2.0 petrol ?????

Similar Threads

  1. Asta h pollen, outdoor temp sensor, coolant sensor locations please
    By Jattxx in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 13-01-2011, 23:42
  2. Coolant control module or coolant temp sensor?
    By andrewdevlin86 in forum Electrical
    Replies: 5
    Last Post: 20-04-2010, 18:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •