Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: jbi motorsport intercooler

  
  1. #1
    Status
    Offline
    FEDZYN888's Avatar
    AOC Lite Member
    Join Date
    Jan 2009
    Posts
    2,351
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Smile jbi motorsport intercooler

    i have just brought a jbi motorsport intercooler kit i started doing abit on it. i wired the slim line fan up tried the connection both way round and the fan light still come on the dash any ideas why? cheers tom

  2. #2
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Arnt these the same as the TX ones?

    Unsure why you got the problem, i just took the fan off my GSi. Its just a light on the dash to me, i live with it not like its doing any damage.

  3. #3
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    you need to use 2 fans to stop the light on the dash as one fan will use less power then the oe fan

  4. #4
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you got climate control? cos i was guna get a slim line fan and he sed cos i have cliate control it may not work...ut i stuck with my standard fan just ad to get correct gaps etc..

  5. #5
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    mine is same if i switch a/c on, or comes on in hot weather after 15mins, didnt come on at all yesterday as was cooler, am waiting 2 buy another fan

  6. #6
    Status
    Offline
    LordNikon's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    18,952
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nyzrox View Post
    Arnt these the same as the TX ones?

    Unsure why you got the problem, i just took the fan off my GSi. Its just a light on the dash to me, i live with it not like its doing any damage.
    So you've removed the fan completely, ie nothing there at all now

  7. #7
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like he has fella....is light will always be on as the fan he has removed backs the main fan up to cool engine down..

  8. #8
    Status
    Offline
    nyzrox's Avatar
    AOC Obsessed
    Join Date
    Apr 2007
    Posts
    1,675
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yes there is no fan....

  9. #9
    Status
    Offline
    LordNikon's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    18,952
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nyzrox View Post
    yes there is no fan....
    You know this provides additional cooling to the main rad fan ............... sorry if you do already just seems an extreme thing to do and then say 'its ok' lol

  10. #10
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hes not bovard mate lol. i no him...

Page 1 of 3 123 LastLast

Similar Threads

  1. Z20LET intercooler vs Z20LEH intercooler!!
    By philj69 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 10
    Last Post: 10-06-2012, 00:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •